Browse Source
Merge pull request #14905 from neheb/vim
vim: fix compile with BUILD_NLS
lilik-openwrt-22.03
Rosen Penev
4 years ago
committed by
GitHub
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
2 changed files with
12 additions and
1 deletions
-
utils/vim/Makefile
-
utils/vim/patches/010-no-msgfmt.patch
|
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk |
|
|
|
|
|
|
|
PKG_NAME:=vim |
|
|
|
PKG_VERSION:=8.2 |
|
|
|
PKG_RELEASE:=2 |
|
|
|
PKG_RELEASE:=3 |
|
|
|
VIMVER:=82 |
|
|
|
|
|
|
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2 |
|
|
|
|
|
@ -0,0 +1,11 @@ |
|
|
|
--- a/src/po/Makefile
|
|
|
|
+++ b/src/po/Makefile
|
|
|
|
@@ -32,7 +32,7 @@ MSGMERGE = OLD_PO_FILE_INPUT=yes OLD_PO_
|
|
|
|
$(VIM) -u NONE -e -X -S check.vim -c "if error == 0 | q | endif" -c cq $< |
|
|
|
touch $@ |
|
|
|
|
|
|
|
-all: $(MOFILES) $(MOCONVERTED) $(MSGFMT_DESKTOP)
|
|
|
|
+all: $(MOFILES) $(MOCONVERTED)
|
|
|
|
|
|
|
|
check: $(CHECKFILES) |
|
|
|
|