Browse Source

vim: fix compile with BUILD_NLS

Avoids having to use msgfmt, which happens to be broken with gettext-full.

msgfmt is used for the desktop gvim application, which is not used here.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 3 years ago
parent
commit
d5ddc98cb6
2 changed files with 12 additions and 1 deletions
  1. +1
    -1
      utils/vim/Makefile
  2. +11
    -0
      utils/vim/patches/010-no-msgfmt.patch

+ 1
- 1
utils/vim/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=vim
PKG_VERSION:=8.2
PKG_RELEASE:=2
PKG_RELEASE:=3
VIMVER:=82
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2


+ 11
- 0
utils/vim/patches/010-no-msgfmt.patch View File

@ -0,0 +1,11 @@
--- a/src/po/Makefile
+++ b/src/po/Makefile
@@ -32,7 +32,7 @@ MSGMERGE = OLD_PO_FILE_INPUT=yes OLD_PO_
$(VIM) -u NONE -e -X -S check.vim -c "if error == 0 | q | endif" -c cq $<
touch $@
-all: $(MOFILES) $(MOCONVERTED) $(MSGFMT_DESKTOP)
+all: $(MOFILES) $(MOCONVERTED)
check: $(CHECKFILES)

Loading…
Cancel
Save