Browse Source

Merge pull request #11657 from jefferyto/newt-remove-patch

newt: Remove python_init_once.patch
lilik-openwrt-22.03
Rosen Penev 5 years ago
committed by GitHub
parent
commit
e592c06b08
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 1 additions and 25 deletions
  1. +1
    -1
      libs/newt/Makefile
  2. +0
    -24
      libs/newt/patches/python_init_once.patch

+ 1
- 1
libs/newt/Makefile View File

@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=newt
PKG_VERSION:=0.52.21
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://releases.pagure.org/newt


+ 0
- 24
libs/newt/patches/python_init_once.patch View File

@ -1,24 +0,0 @@
Author: Alastair McKinstry <mckinstry@debian.org>
Description: newtInit() should only be called once
Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=557960
Forwarded: no
Last-Updated: 2014-06-11
--- a/snack.c
+++ b/snack.c
@@ -377,10 +377,15 @@ static snackWidget * snackWidgetNew (voi
}
static PyObject * initScreen(PyObject * s, PyObject * args) {
+ static int init_newt = 1;
suspend.cb = NULL;
suspend.data = NULL;
newtInit();
+ if (init_newt) {
+ newtInit();
+ init_newt = 0;
+ }
newtCls();
Py_INCREF(Py_None);

Loading…
Cancel
Save