Browse Source

newt: Remove python_init_once.patch

It was pointed out in #11504 that the code in python_init_once.patch is
incorrect; the patch does not prevent newtInit() from being called more
than once (in fact it is called twice the first time initScreen() is
called).

Testing without the patch, using the example code from the corresponding
Debian bug report[1], did not result in any segfaults.

This removes the patch from the package build.

Supersedes #11504.

[1]: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=557960#5

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lilik-openwrt-22.03
Jeffery To 4 years ago
parent
commit
cf1579a75c
2 changed files with 1 additions and 25 deletions
  1. +1
    -1
      libs/newt/Makefile
  2. +0
    -24
      libs/newt/patches/python_init_once.patch

+ 1
- 1
libs/newt/Makefile View File

@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=newt
PKG_VERSION:=0.52.21
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://releases.pagure.org/newt


+ 0
- 24
libs/newt/patches/python_init_once.patch View File

@ -1,24 +0,0 @@
Author: Alastair McKinstry <mckinstry@debian.org>
Description: newtInit() should only be called once
Bug-Debian: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=557960
Forwarded: no
Last-Updated: 2014-06-11
--- a/snack.c
+++ b/snack.c
@@ -377,10 +377,15 @@ static snackWidget * snackWidgetNew (voi
}
static PyObject * initScreen(PyObject * s, PyObject * args) {
+ static int init_newt = 1;
suspend.cb = NULL;
suspend.data = NULL;
newtInit();
+ if (init_newt) {
+ newtInit();
+ init_newt = 0;
+ }
newtCls();
Py_INCREF(Py_None);

Loading…
Cancel
Save