Browse Source

dmx_usb_module: update to 19.12.1

Cleaned up Makefile for consistency between packages.

Remove outdated patch.

Refreshed other one.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 3 years ago
parent
commit
d97056efe5
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
3 changed files with 11 additions and 24 deletions
  1. +8
    -9
      libs/dmx_usb_module/Makefile
  2. +3
    -4
      libs/dmx_usb_module/patches/001-dmx_usb_Makefile.patch
  3. +0
    -11
      libs/dmx_usb_module/patches/002-fix-build-4.14.patch

+ 8
- 9
libs/dmx_usb_module/Makefile View File

@ -9,16 +9,15 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=dmx_usb_module
PKG_VERSION:=0.1.20130818
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_URL:=https://github.com/lowlander/dmx_usb_module.git
PKG_SOURCE_PROTO:=git
PKG_SOURCE_VERSION:=ee99ca7edbd9e093480ad63341ac007394047bde
PKG_VERSION:=19.12.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/lowlander/dmx_usb_module/tar.gz/V$(PKG_VERSION)?
PKG_HASH:=fabeb5500b55197338dda45d07374e5edc837bc18df3ac3114b442fe47cf1b68
PKG_MAINTAINER:=Martijn Zilverschoon <martijn@friedzombie.com>
PKG_LICENSE:=GPL-2.0
PKG_LICENSE:=GPL-2.0-only
include $(INCLUDE_DIR)/package.mk


+ 3
- 4
libs/dmx_usb_module/patches/001-dmx_usb_Makefile.patch View File

@ -1,13 +1,12 @@
--- a/Makefile
+++ b/Makefile
@@ -12,8 +12,7 @@ KDIR := /lib/modules/$(shell uname -r)/build
@@ -12,8 +12,7 @@ KDIR := /lib/modules/$(shell uname -r)/b
PWD := $(shell pwd)
default:
- $(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules
- $(MAKE) -C $(KDIR) M=$(PWD)
- gcc -O2 -pipe -Wall dmx_usb_test.c -o dmx_usb_test
+ $(MAKE) -C $(KERNELPATH) SUBDIRS=$(PWD) modules
+ $(MAKE) -C $(KERNELPATH) M=$(PWD)
endif

+ 0
- 11
libs/dmx_usb_module/patches/002-fix-build-4.14.patch View File

@ -1,11 +0,0 @@
--- a/dmx_usb.c
+++ b/dmx_usb.c
@@ -20,7 +20,7 @@
#include <linux/module.h>
#include <linux/spinlock.h>
#include <linux/completion.h>
-#include <asm/uaccess.h>
+#include <linux/uaccess.h>
#include <linux/usb.h>
#include <linux/version.h>

Loading…
Cancel
Save