Browse Source

Netopeer2: update to 0.6-r1

PR includes switch to codeload tarballs and rename from netopeer2 to
Netopeer2 for better codeload integration.

Signed-off-by: Mislav Novakovic <mislav.novakovic@sartura.hr>
lilik-openwrt-22.03
Mislav Novakovic 6 years ago
parent
commit
d5b3a171b8
10 changed files with 94 additions and 94 deletions
  1. +0
    -0
      net/Netopeer2/Config_keystored.in
  2. +27
    -29
      net/Netopeer2/Makefile
  3. +5
    -5
      net/Netopeer2/files/netopeer2-keystored-keygen.default
  4. +1
    -1
      net/Netopeer2/files/netopeer2-keystored.default
  5. +11
    -1
      net/Netopeer2/files/netopeer2-server.default
  6. +21
    -0
      net/Netopeer2/files/netopeer2-server.init
  7. +0
    -0
      net/Netopeer2/files/stock_config.xml
  8. +11
    -11
      net/Netopeer2/patches/001-fix-for-cmake-build
  9. +18
    -0
      net/Netopeer2/patches/002-fix-keystored-cross-compile
  10. +0
    -47
      net/netopeer2/files/netopeer2-server.init

net/netopeer2/Config_keystored.in → net/Netopeer2/Config_keystored.in View File


net/netopeer2/Makefile → net/Netopeer2/Makefile View File


net/netopeer2/files/netopeer2-keystored-keygen.default → net/Netopeer2/files/netopeer2-keystored-keygen.default View File


net/netopeer2/files/netopeer2-keystored.default → net/Netopeer2/files/netopeer2-keystored.default View File


net/netopeer2/files/netopeer2-server.default → net/Netopeer2/files/netopeer2-server.default View File


+ 21
- 0
net/Netopeer2/files/netopeer2-server.init View File

@ -0,0 +1,21 @@
#!/bin/sh /etc/rc.common
START=99
STOP=11
USE_PROCD=1
PROG=/bin/netopeer2-server
start_service() {
procd_open_instance
procd_set_param command $PROG
procd_append_param command -d -v 0
procd_set_param respawn
procd_close_instance
}
stop_service()
{
service_stop ${PROG}
rm /var/run/netopeer2-server.pid
}

net/netopeer2/files/stock_config.xml → net/Netopeer2/files/stock_config.xml View File


net/netopeer2/patches/001-fix-for-cmake-build → net/Netopeer2/patches/001-fix-for-cmake-build View File


+ 18
- 0
net/Netopeer2/patches/002-fix-keystored-cross-compile View File

@ -0,0 +1,18 @@
Index: Netopeer2-0.6-r1/keystored/CMakeLists.txt
===================================================================
--- Netopeer2-0.6-r1.orig/keystored/CMakeLists.txt
+++ Netopeer2-0.6-r1/keystored/CMakeLists.txt
@@ -69,6 +69,8 @@ find_package(SYSREPO REQUIRED)
target_link_libraries(keystored ${SYSREPO_LIBRARIES})
include_directories(${SYSREPO_INCLUDE_DIRS})
+# skip step because of cross compiling
+if (FALSE)
# get sysrepo plugins directory
if (NOT SR_PLUGINS_DIR)
if (PKG_CONFIG_FOUND)
@@ -154,3 +156,4 @@ add_custom_target(install-scripts-ide-ke
# plugins should be installed into sysrepo plugins dir
install(TARGETS keystored DESTINATION ${SR_PLUGINS_DIR})
+endif()

+ 0
- 47
net/netopeer2/files/netopeer2-server.init View File

@ -1,47 +0,0 @@
#!/bin/sh /etc/rc.common
START=99
STOP=11
USE_PROCD=1
PROG=/bin/netopeer2-server
start_service() {
PERSIST_FILE=/etc/sysrepo/data/ietf-keystore.persist
while [ ! -f $PERSIST_FILE ]
do
echo "no persist file yet"
sleep 3
done
RETRY_CNT=5
LAST_LINE=$(tail -n1 $PERSIST_FILE)
while [[ -f $PERSIST_FILE && $LAST_LINE != "</module>" ]]
do
sleep 1
echo "$RETRY_CNT: $LAST_LINE"
LAST_LINE=$(tail -n1 $PERSIST_FILE)
RETRY_CNT=$(($RETRY_CNT-1))
if [ $RETRY_CNT -le 0 ];
then
rm $PERSIST_FILE
RETRY_CNT=5
fi
done
procd_open_instance
procd_set_param command $PROG
procd_append_param command -d -v 0
procd_set_param respawn
procd_close_instance
}
stop_service()
{
service_stop ${PROG}
}

Loading…
Cancel
Save