|
@ -0,0 +1,18 @@ |
|
|
|
|
|
Index: Netopeer2-0.6-r1/keystored/CMakeLists.txt |
|
|
|
|
|
=================================================================== |
|
|
|
|
|
--- Netopeer2-0.6-r1.orig/keystored/CMakeLists.txt |
|
|
|
|
|
+++ Netopeer2-0.6-r1/keystored/CMakeLists.txt |
|
|
|
|
|
@@ -69,6 +69,8 @@ find_package(SYSREPO REQUIRED) |
|
|
|
|
|
target_link_libraries(keystored ${SYSREPO_LIBRARIES}) |
|
|
|
|
|
include_directories(${SYSREPO_INCLUDE_DIRS}) |
|
|
|
|
|
|
|
|
|
|
|
+# skip step because of cross compiling |
|
|
|
|
|
+if (FALSE) |
|
|
|
|
|
# get sysrepo plugins directory |
|
|
|
|
|
if (NOT SR_PLUGINS_DIR) |
|
|
|
|
|
if (PKG_CONFIG_FOUND) |
|
|
|
|
|
@@ -154,3 +156,4 @@ add_custom_target(install-scripts-ide-ke |
|
|
|
|
|
|
|
|
|
|
|
# plugins should be installed into sysrepo plugins dir |
|
|
|
|
|
install(TARGETS keystored DESTINATION ${SR_PLUGINS_DIR}) |
|
|
|
|
|
+endif() |