Browse Source

glib2: update to 2.70

Remove various outdated patches. No more uClibc and distutils is a
requirement.

Compile host libraries statically. Size is not a concern there. Also
avoids rpath hacks. Disable NLS as well. Avoids gettext dependencies.

Add libpcre dependency. Seems to be a requirement now.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 3 years ago
parent
commit
d2062486e8
4 changed files with 10 additions and 46 deletions
  1. +9
    -12
      libs/glib2/Makefile
  2. +0
    -20
      libs/glib2/patches/004-no-distutils.patch
  3. +0
    -13
      libs/glib2/patches/005-uclibc.patch
  4. +1
    -1
      libs/glib2/patches/006-c99.patch

+ 9
- 12
libs/glib2/Makefile View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=glib2
PKG_VERSION:=2.68.4
PKG_VERSION:=2.70.0
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=glib-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNOME/glib/2.68
PKG_HASH:=62fd061d08a75492617e625a73e2c05e259f831acbb8e1f8b9c81f23f7993a3b
PKG_SOURCE_URL:=@GNOME/glib/2.70
PKG_HASH:=200d7df811c5ba634afbf109f14bb40ba7fde670e89389885da14e27c0840742
PKG_MAINTAINER:=Peter Wagner <tripolar@gmx.at>
PKG_LICENSE:=LGPL-2.1-or-later
@ -22,8 +22,8 @@ PKG_CPE_ID:=cpe:/a:gnome:glib
PKG_BUILD_DIR:=$(BUILD_DIR)/glib-$(PKG_VERSION)
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/glib-$(PKG_VERSION)
PKG_BUILD_DEPENDS:=gettext-full libiconv/host
HOST_BUILD_DEPENDS:=gettext-full/host libiconv/host libffi/host
PKG_BUILD_DEPENDS:=libiconv/host
HOST_BUILD_DEPENDS:=libiconv/host libffi/host pcre/host
PKG_CONFIG_DEPENDS:=CONFIG_BUILD_NLS
PKG_INSTALL:=1
@ -35,7 +35,7 @@ include $(INCLUDE_DIR)/meson.mk
define Package/glib2
SECTION:=libs
CATEGORY:=Libraries
DEPENDS:=$(ICONV_DEPENDS) $(INTL_DEPENDS) +zlib +libpthread +libffi +libattr
DEPENDS:=$(ICONV_DEPENDS) $(INTL_DEPENDS) +zlib +libpthread +libffi +libattr +libpcre
TITLE:=glib 2.0
URL:=http://www.gtk.org/
endef
@ -44,16 +44,14 @@ define Package/glib2/description
The GLib library of C routines
endef
HOST_LDFLAGS += -liconv -Wl,-rpath,$(STAGING_DIR_HOSTPKG)/lib
HOST_LDFLAGS += -Wl,-rpath,$(STAGING_DIR_HOSTPKG)/lib
TARGET_CFLAGS += -ffunction-sections -fdata-sections
TARGET_LDFLAGS += -Wl,--gc-sections $(if $(INTL_FULL),-lintl)
COMP_ARGS= \
-Ddefault_library=both \
-Diconv=external \
-Dselinux=disabled \
-Dlibmount=disabled \
-Dinternal_pcre=true \
-Dman=false \
-Ddtrace=false \
-Dsystemtap=false \
@ -64,15 +62,14 @@ COMP_ARGS= \
-Dfam=false \
-Dtests=false \
-Dinstalled_tests=false \
-Dnls=$(if $(CONFIG_BUILD_NLS),en,dis)abled \
-Doss_fuzz=disabled \
-Dglib_debug=disabled \
-Dglib_assert=false \
-Dglib_checks=false \
-Dlibelf=disabled
MESON_HOST_ARGS += $(COMP_ARGS) -Dxattr=false
MESON_ARGS += $(COMP_ARGS) -Dxattr=true -Db_lto=true
MESON_HOST_ARGS += $(COMP_ARGS) -Dxattr=false -Ddefault_library=static -Dnls=disabled
MESON_ARGS += $(COMP_ARGS) -Dxattr=true -Db_lto=true -Ddefault_library=both -Dnls=$(if $(CONFIG_BUILD_NLS),en,dis)abled
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/bin


+ 0
- 20
libs/glib2/patches/004-no-distutils.patch View File

@ -1,20 +0,0 @@
--- a/meson.build
+++ b/meson.build
@@ -2220,16 +2220,10 @@ endif
glib_conf.set('HAVE_PROC_SELF_CMDLINE', have_proc_self_cmdline)
-python = import('python').find_installation('python3')
+python = 'python3'
# used for '#!/usr/bin/env <name>'
python_name = 'python3'
-python_version = python.language_version()
-python_version_req = '>=3.5'
-if not python_version.version_compare(python_version_req)
- error('Requires Python @0@, @1@ found.'.format(python_version_req, python_version))
-endif
-
# Determine which user environment-dependent files that we want to install
have_bash = find_program('bash', required : false).found() # For completion scripts
bash_comp_dep = dependency('bash-completion', version: '>=2.0', required: false)

+ 0
- 13
libs/glib2/patches/005-uclibc.patch View File

@ -1,13 +0,0 @@
--- a/meson.build
+++ b/meson.build
@@ -2038,8 +2038,8 @@ endif
# FIXME: glib-gettext.m4 has much more checks to detect broken/uncompatible
# implementations. This could be extended if issues are found in some platforms.
libintl_deps = []
-if cc.has_function('ngettext')
- have_bind_textdomain_codeset = cc.has_function('bind_textdomain_codeset')
+if true
+ have_bind_textdomain_codeset = cc.has_function('bind_textdomain_codeset', prefix :'#include <libintl.h>')
else
# First just find the bare library.
libintl = cc.find_library('intl', required : false)

+ 1
- 1
libs/glib2/patches/006-c99.patch View File

@ -1,6 +1,6 @@
--- a/meson.build
+++ b/meson.build
@@ -944,7 +944,7 @@ if host_system == 'windows' and (cc.get_
@@ -949,7 +949,7 @@ if host_system == 'windows' and (cc.get_
glib_conf.set('HAVE_C99_SNPRINTF', false)
glib_conf.set('HAVE_C99_VSNPRINTF', false)
glib_conf.set('HAVE_UNIX98_PRINTF', false)


Loading…
Cancel
Save