You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

13 lines
569 B

--- a/meson.build
+++ b/meson.build
@@ -2038,8 +2038,8 @@ endif
# FIXME: glib-gettext.m4 has much more checks to detect broken/uncompatible
# implementations. This could be extended if issues are found in some platforms.
libintl_deps = []
-if cc.has_function('ngettext')
- have_bind_textdomain_codeset = cc.has_function('bind_textdomain_codeset')
+if true
+ have_bind_textdomain_codeset = cc.has_function('bind_textdomain_codeset', prefix :'#include <libintl.h>')
else
# First just find the bare library.
libintl = cc.find_library('intl', required : false)