Browse Source
Merge pull request #6518 from Ansuel/uwsgites
uwsgi-cgi: fix compilation on Darwin system
lilik-openwrt-22.03
Hannu Nyman
6 years ago
committed by
GitHub
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
2 changed files with
16 additions and
1 deletions
-
net/uwsgi-cgi/Makefile
-
net/uwsgi-cgi/patches/004-hard-code-Linux-as-compilation-os.patch
|
|
@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk |
|
|
|
|
|
|
|
PKG_NAME:=uwsgi-cgi |
|
|
|
PKG_VERSION:=2.0.17.1 |
|
|
|
PKG_RELEASE:=3 |
|
|
|
PKG_RELEASE:=4 |
|
|
|
|
|
|
|
PKG_SOURCE_URL=https://codeload.github.com/unbit/uwsgi/tar.gz/$(PKG_VERSION)? |
|
|
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz |
|
|
|
|
|
@ -0,0 +1,15 @@ |
|
|
|
--- a/uwsgiconfig.py
|
|
|
|
+++ b/uwsgiconfig.py
|
|
|
|
@@ -5,9 +5,9 @@
|
|
|
|
import os |
|
|
|
import re |
|
|
|
import time |
|
|
|
-uwsgi_os = os.uname()[0]
|
|
|
|
-uwsgi_os_k = re.split('[-+_]', os.uname()[2])[0]
|
|
|
|
-uwsgi_os_v = os.uname()[3]
|
|
|
|
+uwsgi_os = "Linux"
|
|
|
|
+uwsgi_os_k = "4.4.0"
|
|
|
|
+uwsgi_os_v = "Linux"
|
|
|
|
uwsgi_cpu = os.uname()[4] |
|
|
|
|
|
|
|
import sys |