Browse Source

uwsgi-cgi: fix compilation on Darwin system

Currently the uwsgiconfig python script append some additional compilation flag based on the host system. This fix some problem related with this by hardcoding usgi_os variable to Linux

Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
lilik-openwrt-22.03
Ansuel Smith 6 years ago
parent
commit
a93066b529
No known key found for this signature in database GPG Key ID: AC001D09ADBFEAD7
2 changed files with 16 additions and 1 deletions
  1. +1
    -1
      net/uwsgi-cgi/Makefile
  2. +15
    -0
      net/uwsgi-cgi/patches/004-hard-code-Linux-as-compilation-os.patch

+ 1
- 1
net/uwsgi-cgi/Makefile View File

@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=uwsgi-cgi
PKG_VERSION:=2.0.17.1
PKG_RELEASE:=3
PKG_RELEASE:=4
PKG_SOURCE_URL=https://codeload.github.com/unbit/uwsgi/tar.gz/$(PKG_VERSION)?
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz


+ 15
- 0
net/uwsgi-cgi/patches/004-hard-code-Linux-as-compilation-os.patch View File

@ -0,0 +1,15 @@
--- a/uwsgiconfig.py
+++ b/uwsgiconfig.py
@@ -5,9 +5,9 @@
import os
import re
import time
-uwsgi_os = os.uname()[0]
-uwsgi_os_k = re.split('[-+_]', os.uname()[2])[0]
-uwsgi_os_v = os.uname()[3]
+uwsgi_os = "Linux"
+uwsgi_os_k = "4.4.0"
+uwsgi_os_v = "Linux"
uwsgi_cpu = os.uname()[4]
import sys

Loading…
Cancel
Save