Browse Source
lcd4linux: Add limits header for PATH_MAX
Fixes compilation on musl.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev
5 years ago
No known key found for this signature in database
GPG Key ID: 36D31CFA845F0E3B
2 changed files with
11 additions and
1 deletions
-
utils/lcd4linux/Makefile
-
utils/lcd4linux/patches/200-musl.patch
|
|
@ -8,7 +8,7 @@ |
|
|
|
include $(TOPDIR)/rules.mk |
|
|
|
|
|
|
|
PKG_NAME:=lcd4linux |
|
|
|
PKG_RELEASE:=1 |
|
|
|
PKG_RELEASE:=2 |
|
|
|
|
|
|
|
PKG_SOURCE_PROTO:=git |
|
|
|
PKG_SOURCE_URL:=https://github.com/feckert/lcd4linux |
|
|
|
|
|
@ -0,0 +1,10 @@ |
|
|
|
--- a/plugin_i2c_sensors.c
|
|
|
|
+++ b/plugin_i2c_sensors.c
|
|
|
|
@@ -68,6 +68,7 @@
|
|
|
|
#include <errno.h> |
|
|
|
#include <fcntl.h> |
|
|
|
#include <dirent.h> |
|
|
|
+#include <limits.h>
|
|
|
|
|
|
|
|
#include "debug.h" |
|
|
|
#include "plugin.h" |