Browse Source

pciutils: Fix pkgconfig file

It's pointing to the host.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 5 years ago
parent
commit
5256c104e8
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
2 changed files with 20 additions and 4 deletions
  1. +17
    -3
      utils/mt-st/patches/010-sysmacros.patch
  2. +3
    -1
      utils/pciutils/Makefile

+ 17
- 3
utils/mt-st/patches/010-sysmacros.patch View File

@ -1,10 +1,24 @@
diff --git a/mt.c b/mt.c
index d4058c0..4837808 100644
--- a/mt.c
+++ b/mt.c
@@ -21,6 +21,7 @@
@@ -20,6 +20,7 @@
#include <fcntl.h>
#include <sys/types.h>
#include <sys/ioctl.h>
#include <sys/stat.h>
+#include <sys/sysmacros.h>
#include <sys/stat.h>
#include <sys/utsname.h>
#include "mtio.h"
diff --git a/stinit.c b/stinit.c
index 5a50341..af5582c 100644
--- a/stinit.c
+++ b/stinit.c
@@ -16,6 +16,7 @@
#include <errno.h>
#include <fcntl.h>
#include <dirent.h>
+#include <limits.h>
#include <sys/stat.h>
#include <sys/ioctl.h>
#include <sys/sysmacros.h>

+ 3
- 1
utils/pciutils/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=pciutils
PKG_VERSION:=3.6.2
PKG_RELEASE:=3
PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/software/utils/pciutils
@ -83,6 +83,8 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) $(PKG_BUILD_DIR)/lib/libpci.pc $(1)/usr/lib/pkgconfig
$(SED) 's,/usr/include,$$$${prefix}/include,g' $(1)/usr/lib/pkgconfig/libpci.pc
$(SED) 's,/usr/lib,$$$${prefix}/lib,g' $(1)/usr/lib/pkgconfig/libpci.pc
$(INSTALL_DIR) $(1)/usr/include/pci
$(CP) $(foreach i,pci.h config.h header.h types.h, \
$(PKG_BUILD_DIR)/lib/$(i)) $(1)/usr/include/pci


Loading…
Cancel
Save