Browse Source

Merge pull request #17297 from nxhack/node_14182

node: bump to 14.18.2
lilik-openwrt-22.03
Josef Schlehofer 3 years ago
committed by GitHub
parent
commit
c5431a7a98
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
2 changed files with 2 additions and 44 deletions
  1. +2
    -2
      lang/node/Makefile
  2. +0
    -42
      lang/node/patches/999-fix_building_with_system_c-ares_on_Linux.patch

+ 2
- 2
lang/node/Makefile View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=node
PKG_VERSION:=v14.18.1
PKG_VERSION:=v14.18.2
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://nodejs.org/dist/$(PKG_VERSION)
PKG_HASH:=3fa1d71adddfab2f5e3e41874b4eddbdf92b65cade4a43922fb1e437afcf89ed
PKG_HASH:=3e8a9ce10f8bcd3628eb6dd049f7f03c84ba9219be6f9743e2221154b9cc680b
PKG_MAINTAINER:=Hirokazu MORIKAWA <morikw2@gmail.com>, Adrian Panella <ianchi74@outlook.com>
PKG_LICENSE:=MIT


+ 0
- 42
lang/node/patches/999-fix_building_with_system_c-ares_on_Linux.patch View File

@ -1,42 +0,0 @@
From 8699aa501c4d4e1567ebe8901e5ec80cadaa9323 Mon Sep 17 00:00:00 2001
From: Felix Yan <felixonmars@archlinux.org>
Date: Thu, 12 Aug 2021 02:44:43 +0800
Subject: [PATCH] deps: fix building with system c-ares on Linux
The change in #39724 breaks building with system c-ares
(`--shared-cares`):
```
In file included from ../src/cares_wrap.cc:25:
../src/cares_wrap.h:25:11: fatal error: ares_nameser.h: No such file or
directory
25 | # include <ares_nameser.h>
| ^~~~~~~~~~~~~~~~
```
Since `ares_nameser.h` isn't available with a default system c-ares
installation, let's add back the include check and use the old
`arpa/nameser.h` routine instead.
Tested to build fine on Arch Linux with shared c-ares.
---
src/cares_wrap.h | 8 ++++++++
1 file changed, 8 insertions(+)
--- a/src/cares_wrap.h
+++ b/src/cares_wrap.h
@@ -22,7 +22,15 @@
# include <netdb.h>
#endif // __POSIX__
+#if defined(__ANDROID__) || \
+ defined(__MINGW32__) || \
+ defined(__OpenBSD__) || \
+ defined(_MSC_VER)
+
# include <ares_nameser.h>
+#else
+# include <arpa/nameser.h>
+#endif
namespace node {
namespace cares_wrap {

Loading…
Cancel
Save