Browse Source

unbound: update to 1.14.0

Signed-off-by: Eric Luehrsen <ericluehrsen@gmail.com>
lilik-openwrt-22.03
Eric Luehrsen 3 years ago
committed by Nick Hainke
parent
commit
824aa45133
3 changed files with 6 additions and 47 deletions
  1. +2
    -2
      net/unbound/Makefile
  2. +4
    -1
      net/unbound/patches/010-configure-uname.patch
  3. +0
    -44
      net/unbound/patches/200-Squelch-permission-denied-errors-for-udp.patch

+ 2
- 2
net/unbound/Makefile View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=unbound
PKG_VERSION:=1.13.2
PKG_VERSION:=1.14.0
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://nlnetlabs.nl/downloads/unbound
PKG_HASH:=0a13b547f3b92a026b5ebd0423f54c991e5718037fd9f72445817f6a040e1a83
PKG_HASH:=6ef91cbf02d5299eab39328c0857393de7b4885a2fe7233ddfe3c124ff5a89c8
PKG_MAINTAINER:=Eric Luehrsen <ericluehrsen@gmail.com>
PKG_LICENSE:=BSD-3-Clause


net/unbound/patches/010-configure_uname.patch → net/unbound/patches/010-configure-uname.patch View File


+ 0
- 44
net/unbound/patches/200-Squelch-permission-denied-errors-for-udp.patch View File

@ -1,44 +0,0 @@
From ad45e9b89ee18bbfeff0ed45da2c243ac17acfe6 Mon Sep 17 00:00:00 2001
From: "W.C.A. Wijngaards" <wouter@nlnetlabs.nl>
Date: Fri, 13 Aug 2021 09:27:58 +0200
Subject: [PATCH] - Fix for #431: Squelch permission denied errors for udp
connect, and udp send, they are visible at higher verbosity settings.
---
doc/Changelog | 2 ++
services/outside_network.c | 1 +
util/netevent.c | 1 +
3 files changed, 4 insertions(+)
# diff --git a/doc/Changelog b/doc/Changelog
# index 62c747c85..1cd0f3bad 100644
# --- a/doc/Changelog
# +++ b/doc/Changelog
# @@ -1,5 +1,7 @@
# 13 August 2021: Wouter
# - Support using system-wide crypto policies.
# + - Fix for #431: Squelch permission denied errors for udp connect,
# + and udp send, they are visible at higher verbosity settings.
# 12 August 2021: George
# - Merge PR #514, from ziollek: Docker environment for run tests.
--- a/services/outside_network.c
+++ b/services/outside_network.c
@@ -1962,6 +1962,7 @@ static int udp_connect_needs_log(int err
case ENETDOWN:
# endif
case EPERM:
+ case EACCES:
if(verbosity >= VERB_ALGO)
return 1;
return 0;
--- a/util/netevent.c
+++ b/util/netevent.c
@@ -300,6 +300,7 @@ udp_send_errno_needs_log(struct sockaddr
case ENETDOWN:
# endif
case EPERM:
+ case EACCES:
if(verbosity < VERB_ALGO)
return 0;
default:

Loading…
Cancel
Save