Browse Source

Merge pull request #1524 from sairon/python3-disable-wcsftime-detection

python3: disable usage of wcsftime (broken in uClibc)
lilik-openwrt-22.03
Steven Barth 9 years ago
parent
commit
a9f7dfb886
2 changed files with 14 additions and 1 deletions
  1. +1
    -1
      lang/python3/Makefile
  2. +13
    -0
      lang/python3/patches/012-disable-wcsftime-detection.patch

+ 1
- 1
lang/python3/Makefile View File

@ -14,7 +14,7 @@ PYTHON_VERSION:=$(PYTHON3_VERSION)
PYTHON_VERSION_MICRO:=$(PYTHON3_VERSION_MICRO)
PKG_NAME:=python3
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz


+ 13
- 0
lang/python3/patches/012-disable-wcsftime-detection.patch View File

@ -0,0 +1,13 @@
diff --git a/configure b/configure
index 274af7e..85bbf0e 100755
--- a/configure
+++ b/configure
@@ -10555,7 +10555,7 @@ for ac_func in alarm accept4 setitimer getitimer bind_textdomain_codeset chown \
sigtimedwait sigwait sigwaitinfo snprintf strftime strlcpy symlinkat sync \
sysconf tcgetpgrp tcsetpgrp tempnam timegm times tmpfile tmpnam tmpnam_r \
truncate uname unlinkat unsetenv utimensat utimes waitid waitpid wait3 wait4 \
- wcscoll wcsftime wcsxfrm wmemcmp writev _getpty
+ wcscoll wcsxfrm wmemcmp writev _getpty
do :
as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
ac_fn_c_check_func "$LINENO" "$ac_func" "$as_ac_var"

Loading…
Cancel
Save