Browse Source

Merge pull request #1526 from sairon/python-fix-host-multiarch-support

python: fix patch removing multiarch support for host python
lilik-openwrt-22.03
Steven Barth 10 years ago
parent
commit
f24dd77eb7
2 changed files with 5 additions and 3 deletions
  1. +1
    -1
      lang/python/Makefile
  2. +4
    -2
      lang/python/patches/006-remove-debian-multiarch-support.patch

+ 1
- 1
lang/python/Makefile View File

@ -12,7 +12,7 @@ include ./files/python-package.mk
PKG_NAME:=python
PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
PKG_RELEASE:=5
PKG_RELEASE:=6
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://www.python.org/ftp/python/$(PKG_VERSION)


+ 4
- 2
lang/python/patches/006-remove-debian-multiarch-support.patch View File

@ -1,12 +1,14 @@
diff --git a/setup.py b/setup.py
index 7868b7b..9ae0ef2 100644
index 1d1ae72..511aed5 100644
--- a/setup.py
+++ b/setup.py
@@ -444,7 +444,6 @@ class PyBuildExt(build_ext):
@@ -444,7 +444,8 @@ class PyBuildExt(build_ext):
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
if cross_compiling:
self.add_gcc_paths()
- self.add_multiarch_paths()
+ else:
+ self.add_multiarch_paths()
# Add paths specified in the environment variables LDFLAGS and
# CPPFLAGS for header and library files.

Loading…
Cancel
Save