Browse Source
Merge pull request #13262 from neheb/ksm
kismet: fix compilation under uClibc-ng and GCC10
lilik-openwrt-22.03
Rosen Penev
4 years ago
committed by
GitHub
No known key found for this signature in database
GPG Key ID: 4AEE18F83AFDEB23
2 changed files with
13 additions and
1 deletions
-
net/kismet/Makefile
-
net/kismet/patches/040-uclibc.patch
|
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk |
|
|
|
|
|
|
|
PKG_NAME:=kismet |
|
|
|
PKG_VERSION:=2016-07-R1 |
|
|
|
PKG_RELEASE:=4 |
|
|
|
PKG_RELEASE:=5 |
|
|
|
|
|
|
|
PKG_LICENSE:=LGPLv2.1 |
|
|
|
PKG_CPE_ID:=cpe:/a:kismet:kismet |
|
|
|
|
|
@ -0,0 +1,12 @@ |
|
|
|
--- a/ipc_remote.cc
|
|
|
|
+++ b/ipc_remote.cc
|
|
|
|
@@ -941,8 +941,8 @@ int RootIPCRemote::OpenFDPassSock() {
|
|
|
|
} |
|
|
|
|
|
|
|
typedef struct { |
|
|
|
- struct cmsghdr header;
|
|
|
|
int fd; |
|
|
|
+ struct cmsghdr header;
|
|
|
|
} __attribute__((packed)) cmsg_fd; |
|
|
|
|
|
|
|
int RootIPCRemote::SendDescriptor(int in_fd) { |