Browse Source

kismet: fix compilation under uClibc-ng and GCC10

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 4 years ago
parent
commit
d897beee91
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
2 changed files with 13 additions and 1 deletions
  1. +1
    -1
      net/kismet/Makefile
  2. +12
    -0
      net/kismet/patches/040-uclibc.patch

+ 1
- 1
net/kismet/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=kismet
PKG_VERSION:=2016-07-R1
PKG_RELEASE:=4
PKG_RELEASE:=5
PKG_LICENSE:=LGPLv2.1
PKG_CPE_ID:=cpe:/a:kismet:kismet


+ 12
- 0
net/kismet/patches/040-uclibc.patch View File

@ -0,0 +1,12 @@
--- a/ipc_remote.cc
+++ b/ipc_remote.cc
@@ -941,8 +941,8 @@ int RootIPCRemote::OpenFDPassSock() {
}
typedef struct {
- struct cmsghdr header;
int fd;
+ struct cmsghdr header;
} __attribute__((packed)) cmsg_fd;
int RootIPCRemote::SendDescriptor(int in_fd) {

Loading…
Cancel
Save