Browse Source

python,python3: remove multi-arch support, and /usr/local paths

This should hopefully reduce weird behaviour caused
by the host system.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lilik-openwrt-22.03
Alexandru Ardelean 8 years ago
parent
commit
84202f17e1
6 changed files with 41 additions and 28 deletions
  1. +1
    -1
      lang/python/python/Makefile
  2. +0
    -14
      lang/python/python/patches/006-remove-debian-multiarch-support.patch
  3. +18
    -0
      lang/python/python/patches/006-remove-multi-arch-and-local-paths.patch
  4. +1
    -1
      lang/python/python3/Makefile
  5. +0
    -12
      lang/python/python3/patches/006-remove-debian-multiarch-support.patch
  6. +21
    -0
      lang/python/python3/patches/006-remove-multi-arch-and-local-paths.patch

+ 1
- 1
lang/python/python/Makefile View File

@ -12,7 +12,7 @@ include ./files/python-version.mk
PKG_NAME:=python
PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
PKG_RELEASE:=5
PKG_RELEASE:=6
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)


+ 0
- 14
lang/python/python/patches/006-remove-debian-multiarch-support.patch View File

@ -1,14 +0,0 @@
diff --git a/setup.py b/setup.py
index 1d1ae72..511aed5 100644
--- a/setup.py
+++ b/setup.py
@@ -444,7 +444,8 @@ class PyBuildExt(build_ext):
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
if cross_compiling:
self.add_gcc_paths()
- self.add_multiarch_paths()
+ else:
+ self.add_multiarch_paths()
# Add paths specified in the environment variables LDFLAGS and
# CPPFLAGS for header and library files.

+ 18
- 0
lang/python/python/patches/006-remove-multi-arch-and-local-paths.patch View File

@ -0,0 +1,18 @@
diff --git a/setup.py b/setup.py
index 54054c2..d043761 100644
--- a/setup.py
+++ b/setup.py
@@ -454,13 +454,8 @@ class PyBuildExt(build_ext):
os.unlink(tmpfile)
def detect_modules(self):
- # Ensure that /usr/local is always used
- if not cross_compiling:
- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
- add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
if cross_compiling:
self.add_gcc_paths()
- self.add_multiarch_paths()
# Add paths specified in the environment variables LDFLAGS and
# CPPFLAGS for header and library files.

+ 1
- 1
lang/python/python3/Makefile View File

@ -14,7 +14,7 @@ PYTHON_VERSION:=$(PYTHON3_VERSION)
PYTHON_VERSION_MICRO:=$(PYTHON3_VERSION_MICRO)
PKG_NAME:=python3
PKG_RELEASE:=3
PKG_RELEASE:=4
PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz


+ 0
- 12
lang/python/python3/patches/006-remove-debian-multiarch-support.patch View File

@ -1,12 +0,0 @@
diff --git a/setup.py b/setup.py
index 7868b7b..9ae0ef2 100644
--- a/setup.py
+++ b/setup.py
@@ -444,7 +444,6 @@ class PyBuildExt(build_ext):
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
if cross_compiling:
self.add_gcc_paths()
- self.add_multiarch_paths()
# Add paths specified in the environment variables LDFLAGS and
# CPPFLAGS for header and library files.

+ 21
- 0
lang/python/python3/patches/006-remove-multi-arch-and-local-paths.patch View File

@ -0,0 +1,21 @@
diff --git a/setup.py b/setup.py
index f04bf22..01b851e 100644
--- a/setup.py
+++ b/setup.py
@@ -487,16 +487,9 @@ class PyBuildExt(build_ext):
return ['m']
def detect_modules(self):
- # Ensure that /usr/local is always used, but the local build
- # directories (i.e. '.' and 'Include') must be first. See issue
- # 10520.
- if not cross_compiling:
- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
- add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
# only change this for cross builds for 3.3, issues on Mageia
if cross_compiling:
self.add_gcc_paths()
- self.add_multiarch_paths()
# Add paths specified in the environment variables LDFLAGS and
# CPPFLAGS for header and library files.

Loading…
Cancel
Save