This should hopefully reduce weird behaviour caused by the host system. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>lilik-openwrt-22.03
@ -1,14 +0,0 @@ | |||||
diff --git a/setup.py b/setup.py | |||||
index 1d1ae72..511aed5 100644 | |||||
--- a/setup.py | |||||
+++ b/setup.py | |||||
@@ -444,7 +444,8 @@ class PyBuildExt(build_ext): | |||||
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include') | |||||
if cross_compiling: | |||||
self.add_gcc_paths() | |||||
- self.add_multiarch_paths() | |||||
+ else: | |||||
+ self.add_multiarch_paths() | |||||
# Add paths specified in the environment variables LDFLAGS and | |||||
# CPPFLAGS for header and library files. |
@ -0,0 +1,18 @@ | |||||
diff --git a/setup.py b/setup.py | |||||
index 54054c2..d043761 100644 | |||||
--- a/setup.py | |||||
+++ b/setup.py | |||||
@@ -454,13 +454,8 @@ class PyBuildExt(build_ext): | |||||
os.unlink(tmpfile) | |||||
def detect_modules(self): | |||||
- # Ensure that /usr/local is always used | |||||
- if not cross_compiling: | |||||
- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib') | |||||
- add_dir_to_list(self.compiler.include_dirs, '/usr/local/include') | |||||
if cross_compiling: | |||||
self.add_gcc_paths() | |||||
- self.add_multiarch_paths() | |||||
# Add paths specified in the environment variables LDFLAGS and | |||||
# CPPFLAGS for header and library files. |
@ -1,12 +0,0 @@ | |||||
diff --git a/setup.py b/setup.py | |||||
index 7868b7b..9ae0ef2 100644 | |||||
--- a/setup.py | |||||
+++ b/setup.py | |||||
@@ -444,7 +444,6 @@ class PyBuildExt(build_ext): | |||||
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include') | |||||
if cross_compiling: | |||||
self.add_gcc_paths() | |||||
- self.add_multiarch_paths() | |||||
# Add paths specified in the environment variables LDFLAGS and | |||||
# CPPFLAGS for header and library files. |
@ -0,0 +1,21 @@ | |||||
diff --git a/setup.py b/setup.py | |||||
index f04bf22..01b851e 100644 | |||||
--- a/setup.py | |||||
+++ b/setup.py | |||||
@@ -487,16 +487,9 @@ class PyBuildExt(build_ext): | |||||
return ['m'] | |||||
def detect_modules(self): | |||||
- # Ensure that /usr/local is always used, but the local build | |||||
- # directories (i.e. '.' and 'Include') must be first. See issue | |||||
- # 10520. | |||||
- if not cross_compiling: | |||||
- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib') | |||||
- add_dir_to_list(self.compiler.include_dirs, '/usr/local/include') | |||||
# only change this for cross builds for 3.3, issues on Mageia | |||||
if cross_compiling: | |||||
self.add_gcc_paths() | |||||
- self.add_multiarch_paths() | |||||
# Add paths specified in the environment variables LDFLAGS and | |||||
# CPPFLAGS for header and library files. |