Browse Source

addrwatch: Add missing limits header for PATH_MAX

Fixes compilation on musl.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 5 years ago
parent
commit
8003eea2b9
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
2 changed files with 11 additions and 1 deletions
  1. +1
    -1
      net/addrwatch/Makefile
  2. +10
    -0
      net/addrwatch/patches/010-limits.patch

+ 1
- 1
net/addrwatch/Makefile View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=addrwatch
PKG_VERSION:=1.0.1
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/fln/addrwatch/tar.gz/v$(PKG_VERSION)?


+ 10
- 0
net/addrwatch/patches/010-limits.patch View File

@ -0,0 +1,10 @@
--- a/src/addrwatch.c
+++ b/src/addrwatch.c
@@ -4,6 +4,7 @@
#include <signal.h>
#include <strings.h>
#include <unistd.h>
+#include <limits.h>
#include <pwd.h>
#include <grp.h>
#include <argp.h>

Loading…
Cancel
Save