Browse Source
addrwatch: Add missing limits header for PATH_MAX
Fixes compilation on musl.
Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev
5 years ago
No known key found for this signature in database
GPG Key ID: 36D31CFA845F0E3B
2 changed files with
11 additions and
1 deletions
-
net/addrwatch/Makefile
-
net/addrwatch/patches/010-limits.patch
|
|
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk |
|
|
|
|
|
|
|
PKG_NAME:=addrwatch |
|
|
|
PKG_VERSION:=1.0.1 |
|
|
|
PKG_RELEASE:=2 |
|
|
|
PKG_RELEASE:=3 |
|
|
|
|
|
|
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz |
|
|
|
PKG_SOURCE_URL:=https://codeload.github.com/fln/addrwatch/tar.gz/v$(PKG_VERSION)? |
|
|
|
|
|
@ -0,0 +1,10 @@ |
|
|
|
--- a/src/addrwatch.c
|
|
|
|
+++ b/src/addrwatch.c
|
|
|
|
@@ -4,6 +4,7 @@
|
|
|
|
#include <signal.h> |
|
|
|
#include <strings.h> |
|
|
|
#include <unistd.h> |
|
|
|
+#include <limits.h>
|
|
|
|
#include <pwd.h> |
|
|
|
#include <grp.h> |
|
|
|
#include <argp.h> |