Browse Source

fcgi: remove

Nothing uses this.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 5 years ago
parent
commit
65ef6c646a
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
2 changed files with 0 additions and 112 deletions
  1. +0
    -77
      libs/fcgi/Makefile
  2. +0
    -35
      libs/fcgi/patches/100-fcgio-int-type-fix.patch

+ 0
- 77
libs/fcgi/Makefile View File

@ -1,77 +0,0 @@
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=fcgi
PKG_VERSION:=2.4.2
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)2-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/FastCGI-Archives/fcgi2/tar.gz/$(PKG_VERSION)?
PKG_HASH:=1fe83501edfc3a7ec96bb1e69db3fd5ea1730135bd73ab152186fd0b437013bc
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)2-$(PKG_VERSION)
PKG_MAINTAINER:=Jacob Siverskog <jacob@teenageengineering.com>
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=LICENSE.TERMS
PKG_FIXUP:=autoreconf
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
include $(INCLUDE_DIR)/uclibc++.mk
include $(INCLUDE_DIR)/package.mk
define Package/fcgi/Default
SECTION:=libs
CATEGORY:=Libraries
URL:=https://fastcgi-archives.github.io/
endef
define Package/fcgi
$(call Package/fcgi/Default)
MENU:=1
DEPENDS:=+libpthread
TITLE:=Shared library of FastCGI
endef
define Package/fcgixx
$(call Package/fcgi/Default)
DEPENDS:=fcgi $(CXX_DEPENDS)
TITLE:=Shared library of FastCGI++
endef
define Package/fcgi/description
FastCGI is a language independent, scalable, open extension to
CGI that provides high performance without the limitations of
server specific APIs.
endef
TARGET_CXXFLAGS += -fno-rtti -flto
TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/fastcgi.h $(1)/usr/include/
$(CP) $(PKG_INSTALL_DIR)/usr/include/fcgi{app,_config,misc,o,os,_stdio}.h $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libfcgi{,++}.{a,so*} $(1)/usr/lib/
endef
define Package/fcgi/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/cgi-fcgi $(1)/usr/bin/
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libfcgi.so.* $(1)/usr/lib/
endef
define Package/fcgixx/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libfcgi++.so.* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,fcgi))
$(eval $(call BuildPackage,fcgixx))

+ 0
- 35
libs/fcgi/patches/100-fcgio-int-type-fix.patch View File

@ -1,35 +0,0 @@
--- a/include/fcgio.h
+++ b/include/fcgio.h
@@ -77,10 +77,10 @@ protected:
virtual int sync();
// Remove and return the current character.
- virtual int uflow();
+ virtual int_type uflow();
// Fill the get area (if buffered) and return the current character.
- virtual int underflow();
+ virtual int_type underflow();
// Use a buffer. The only reasons that a buffer would be useful is
// to support the use of the unget()/putback() or seek() methods. Using
--- a/libfcgi/fcgio.cpp
+++ b/libfcgi/fcgio.cpp
@@ -86,7 +86,7 @@ int fcgi_streambuf::sync()
}
// uflow() removes the char, underflow() doesn't
-int fcgi_streambuf::uflow()
+std::basic_streambuf<char>::int_type fcgi_streambuf::uflow()
{
if (this->bufsize)
{
@@ -100,7 +100,7 @@ int fcgi_streambuf::uflow()
}
}
-int fcgi_streambuf::underflow()
+std::basic_streambuf<char>::int_type fcgi_streambuf::underflow()
{
if (this->bufsize)
{

Loading…
Cancel
Save