Browse Source

classpath: remove

This no longer builds as GCC no longer includes Java support.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 5 years ago
parent
commit
27f871473d
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
3 changed files with 0 additions and 196 deletions
  1. +0
    -95
      libs/classpath/Makefile
  2. +0
    -91
      libs/classpath/patches/010-double-memleak.patch
  3. +0
    -10
      libs/classpath/patches/020-fix-statement-may-fall-through.patch

+ 0
- 95
libs/classpath/Makefile View File

@ -1,95 +0,0 @@
#
# Copyright (C) 2006-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=classpath
PKG_VERSION:=0.99
PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@GNU/classpath
PKG_HASH:=f929297f8ae9b613a1a167e231566861893260651d913ad9b6c11933895fecc8
PKG_MAINTAINER:=Dana H. Myers <k6jq@comcast.net>
PKG_LICENSE:=GPL-2.0-or-later
PKG_LICENSE_FILES:=COPYING
PKG_CPE_ID:=cpe:/a:gnu:classpath
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
PKG_BUILD_DEPENDS:=jamvm/host
include $(INCLUDE_DIR)/package.mk
define Package/classpath
SECTION:=libs
CATEGORY:=Libraries
TITLE:=GNU Classpath
URL:=https://www.gnu.org/software/classpath/
DEPENDS:=+alsa-lib +libgmp +libmagic
endef
define Package/classpath/Description
GNU Classpath, Essential Libraries for Java, is a GNU project
to create free core class libraries for use with virtual
machines and compilers for the java programming language.
endef
define Package/classpath-tools
SECTION:=libs
CATEGORY:=Libraries
TITLE:=GNU Classpath tools
URL:=https://www.gnu.org/software/classpath/
endef
define Download/antlr
URL:=https://www.antlr.org/download
FILE:=antlr-3.4-complete.jar
HASH:=9d3e866b610460664522520f73b81777b5626fb0a282a5952b9800b751550bf7
endef
$(eval $(call Download,antlr))
EXTRA_CFLAGS += -Wno-error=implicit-fallthrough
CONFIGURE_ARGS += \
--with-gmp="$(STAGING_DIR)/usr" \
--without-x \
--disable-gtk-peer \
--disable-qt-peer \
--disable-dssi \
--disable-plugin \
--disable-gconf-peer \
--disable-gjdoc \
--disable-examples \
--with-antlr-jar=$(DL_DIR)/antlr-3.4-complete.jar
define Package/classpath/install
$(INSTALL_DIR) \
$(1)/usr/lib/classpath \
$(1)/usr/share/classpath
$(CP) \
$(PKG_INSTALL_DIR)/usr/lib/security \
$(PKG_INSTALL_DIR)/usr/lib/logging.properties \
$(1)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/classpath/*.so* $(1)/usr/lib/classpath/
$(CP) $(PKG_INSTALL_DIR)/usr/share/classpath/glibj.zip $(1)/usr/share/classpath/
endef
define Package/classpath-tools/install
$(INSTALL_DIR) \
$(1)/usr/bin \
$(1)/usr/share/classpath
$(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
$(CP) $(PKG_INSTALL_DIR)/usr/share/classpath/tools.zip $(1)/usr/share/classpath/
endef
define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/* $(1)/
endef
$(eval $(call BuildPackage,classpath))
$(eval $(call BuildPackage,classpath-tools))

+ 0
- 91
libs/classpath/patches/010-double-memleak.patch View File

@ -1,91 +0,0 @@
--- classpath-0.99.orig/native/fdlibm/dtoa.c 2007-09-27 05:33:38.000000000 -0700
+++ classpath-0.99/native/fdlibm/dtoa.c 2014-12-21 14:22:42.451713851 -0800
@@ -883,6 +883,16 @@ ret1:
return s0;
}
+void free_Bigints(struct _Jv_Bigint *p)
+{
+ struct _Jv_Bigint *l = p;
+ while (l)
+ {
+ struct _Jv_Bigint *next = l->_next;
+ free (l);
+ l = next;
+ }
+}
_VOID
_DEFUN (_dtoa,
@@ -905,16 +915,15 @@ _DEFUN (_dtoa,
p = _dtoa_r (&reent, _d, mode, ndigits, decpt, sign, rve, float_type);
strcpy (buf, p);
- for (i = 0; i < reent._result_k; ++i)
+ for (i = 0; i < reent._max_k; ++i)
{
- struct _Jv_Bigint *l = reent._freelist[i];
- while (l)
- {
- struct _Jv_Bigint *next = l->_next;
- free (l);
- l = next;
- }
+ free_Bigints(reent._freelist[i]);
}
if (reent._freelist)
free (reent._freelist);
+
+ if (reent._result)
+ free(reent._result);
+
+ free_Bigints(reent._p5s);
}
--- classpath-0.99.orig/native/jni/java-lang/java_lang_VMDouble.c 2008-02-08 09:42:57.000000000 -0800
+++ classpath-0.99/native/jni/java-lang/java_lang_VMDouble.c 2014-12-21 14:35:50.733800626 -0800
@@ -158,6 +158,17 @@ Java_java_lang_VMDouble_longBitsToDouble
return val.d;
}
+static void free_Bigints(struct _Jv_Bigint *p)
+{
+ struct _Jv_Bigint *l = p;
+ while (l)
+ {
+ struct _Jv_Bigint *next = l->_next;
+ free (l);
+ l = next;
+ }
+}
+
/**
* Parse a double from a char array.
*/
@@ -167,7 +178,7 @@ parseDoubleFromChars(JNIEnv * env, const
char *endptr;
jdouble val = 0.0;
const char *p = buf, *end, *last_non_ws, *temp;
- int ok = 1;
+ int i, ok = 1;
#ifdef DEBUG
fprintf (stderr, "java.lang.VMDouble.parseDouble (%s)\n", buf);
@@ -224,6 +235,18 @@ parseDoubleFromChars(JNIEnv * env, const
val = _strtod_r (&reent, p, &endptr);
+ for (i = 0; i < reent._max_k; ++i)
+ {
+ free_Bigints(reent._freelist[i]);
+ }
+ if (reent._freelist)
+ free (reent._freelist);
+
+ if (reent._result)
+ free (reent._result);
+
+ free_Bigints(reent._p5s);
+
#ifdef DEBUG
fprintf (stderr, "java.lang.VMDouble.parseDouble val = %g\n", val);
fprintf (stderr, "java.lang.VMDouble.parseDouble %p != %p ???\n",

+ 0
- 10
libs/classpath/patches/020-fix-statement-may-fall-through.patch View File

@ -1,10 +0,0 @@
--- a/native/jni/java-math/gnu_java_math_GMP.c
+++ b/native/jni/java-math/gnu_java_math_GMP.c
@@ -1132,6 +1132,7 @@
break;
case 1:
res = mpz_popcount (_this);
+ __attribute__((fallthrough));
default:
JCL_ThrowException (env, "java/lang/Error",
"Unexpected sign value for a native MPI");

Loading…
Cancel
Save