Browse Source

isc-dhcp: Update to 4.4.3

Note that on 32-bit ARM with MUSL we don't have Unwind_GetIP() so
we need to disable backtraces.

Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
lilik-openwrt-22.03
Philip Prindeville 2 years ago
parent
commit
649244dae2
4 changed files with 23 additions and 15 deletions
  1. +6
    -5
      net/isc-dhcp/Makefile
  2. +0
    -9
      net/isc-dhcp/patches/000-compile.patch
  3. +1
    -1
      net/isc-dhcp/patches/510-bind-CC.patch
  4. +16
    -0
      net/isc-dhcp/patches/900-pass-in-bindconfig.patch

+ 6
- 5
net/isc-dhcp/Makefile View File

@ -9,8 +9,8 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=isc-dhcp
UPSTREAM_NAME:=dhcp
PKG_VERSION:=4.4.1
PKG_RELEASE:=20
PKG_VERSION:=4.4.3
PKG_RELEASE:=$(AUTORELEASE)
PKG_LICENSE:=BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE
@ -21,7 +21,7 @@ PKG_SOURCE:=$(UPSTREAM_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://ftp.isc.org/isc/dhcp/$(PKG_VERSION) \
http://ftp.funet.fi/pub/mirrors/ftp.isc.org/isc/dhcp/$(PKG_VERSION) \
http://ftp.iij.ad.jp/pub/network/isc/dhcp/$(PKG_VERSION)
PKG_HASH:=2a22508922ab367b4af4664a0472dc220cc9603482cf3c16d9aff14f3a76b608
PKG_HASH:=0e3ec6b4c2a05ec0148874bcd999a66d05518378d77421f607fb0bc9d0135818
PKG_FIXUP:=autoreconf
PKG_BUILD_PARALLEL:=1
@ -193,8 +193,9 @@ endef
CONFIGURE_ARGS += \
--enable-paranoia \
--disable-dependency-tracking \
--with-randomdev=/dev/urandom \
ac_cv_path_AR=$(TARGET_AR) \
--with-randomdev=/dev/urandom \
--disable-backtrace \
ac_cv_path_AR=$(TARGET_AR) \
ac_cv_file__dev_random=yes
ifeq ($(BUILD_VARIANT),ipv4)


+ 0
- 9
net/isc-dhcp/patches/000-compile.patch View File

@ -1,9 +0,0 @@
--- a/bind/Makefile.in
+++ b/bind/Makefile.in
@@ -116,5 +116,6 @@ uninstall-bind: all
# Include the following so that this Makefile is happy when the parent
# tries to use them.
+install-exec:
check distdir distclean dvi installcheck:

+ 1
- 1
net/isc-dhcp/patches/510-bind-CC.patch View File

@ -13,4 +13,4 @@
+ --without-randomdev > ${binddir}/configure.log); \
fi
atf:
atf: bind1

+ 16
- 0
net/isc-dhcp/patches/900-pass-in-bindconfig.patch View File

@ -0,0 +1,16 @@
--- a/configure.ac
+++ b/configure.ac
@@ -660,6 +660,13 @@ else
BINDCONFIG="$BINDCONFIG --with-randomdev=$use_randomdev"
fi
+AC_ARG_ENABLE(backtrace,
+ AS_HELP_STRING([--enable-backtrace], [use libunwind backtracing (default is yes)]),
+ want_backtrace="$enableval", want_backtrace="yes")
+if test "$want_backtrace" = "no"; then
+ BINDCONFIG="$BINDCONFIG --disable-backtrace"
+fi
+
BINDIOMUX="--disable-kqueue --disable-epoll --disable-devpoll"
# check kqueue/epoll/devpoll alternative to select
AC_ARG_ENABLE(kqueue,

Loading…
Cancel
Save