Browse Source

Revert "python: don't use libressl for host build"

This reverts commit ca800e60b0.
lilik-openwrt-22.03
Alexandru Ardelean 8 years ago
parent
commit
515468346a
2 changed files with 1 additions and 12 deletions
  1. +1
    -1
      lang/python/Makefile
  2. +0
    -11
      lang/python/patches/012-disable-openssl-for-hashlib-on-host-build.patch

+ 1
- 1
lang/python/Makefile View File

@ -12,7 +12,7 @@ include ./files/python-version.mk
PKG_NAME:=python
PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
PKG_RELEASE:=2
PKG_RELEASE:=1
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)


+ 0
- 11
lang/python/patches/012-disable-openssl-for-hashlib-on-host-build.patch View File

@ -1,11 +0,0 @@
--- a/setup.py
+++ b/setup.py
@@ -859,7 +859,7 @@ class PyBuildExt(build_ext):
min_openssl_ver = 0x00907000
have_any_openssl = ssl_incs is not None and ssl_libs is not None
- have_usable_openssl = (have_any_openssl and
+ have_usable_openssl = cross_compiling and (have_any_openssl and
openssl_ver >= min_openssl_ver)
if have_any_openssl:

Loading…
Cancel
Save