Browse Source

python: don't use libressl for host build

Fixes: https://github.com/openwrt/packages/issues/3767

Since commit:
f6e6341d89

libressl is built on the host-side.

Python picks it up [ via the openssl/* headers ] and assumes
it has SSL libs.
Compiling works fine, linking fails.
Doesn't look like it's because:
2fd5ce9488

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lilik-openwrt-22.03
Alexandru Ardelean 8 years ago
parent
commit
ca800e60b0
2 changed files with 12 additions and 1 deletions
  1. +1
    -1
      lang/python/Makefile
  2. +11
    -0
      lang/python/patches/012-disable-openssl-for-hashlib-on-host-build.patch

+ 1
- 1
lang/python/Makefile View File

@ -12,7 +12,7 @@ include ./files/python-version.mk
PKG_NAME:=python
PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)


+ 11
- 0
lang/python/patches/012-disable-openssl-for-hashlib-on-host-build.patch View File

@ -0,0 +1,11 @@
--- a/setup.py
+++ b/setup.py
@@ -859,7 +859,7 @@ class PyBuildExt(build_ext):
min_openssl_ver = 0x00907000
have_any_openssl = ssl_incs is not None and ssl_libs is not None
- have_usable_openssl = (have_any_openssl and
+ have_usable_openssl = cross_compiling and (have_any_openssl and
openssl_ver >= min_openssl_ver)
if have_any_openssl:

Loading…
Cancel
Save