Browse Source

rxtx: remove

This does not build as GCC no longer includes Java support.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 5 years ago
parent
commit
7b02849f51
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
2 changed files with 0 additions and 60 deletions
  1. +0
    -49
      libs/rxtx/Makefile
  2. +0
    -11
      libs/rxtx/patches/010-acm-devices.patch

+ 0
- 49
libs/rxtx/Makefile View File

@ -1,49 +0,0 @@
#
# Copyright (C) 2016 Dana H. Myers <k6jq@comcast.net>
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=rxtx
PKG_VERSION:=2.2pre2
PKG_RELEASE:=1
PKG_LICENSE:=LGPL-2.1
PKG_MAINTAINER:=Dana H. Myers <k6jq@comcast.net>
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
PKG_SOURCE_URL:=http://rxtx.qbang.org/pub/rxtx/
PKG_HASH:=3c30373e760f444def3650c76c5a00ae12fb1d860ec008750d084f4880495b03
PKG_FIXUP:=patch-libtool
PKG_CHECK_FORMAT_SECURITY:=0
include $(INCLUDE_DIR)/package.mk
define Package/rxtx
SECTION:=libs
CATEGORY:=Libraries
TITLE:=RX/TX Support for Java serial communications
URL:=http://rxtx.qbang.org/wiki/index.php/Main_Page
DEPENDS:=+libpthread +classpath
endef
define Package/rxtx/description
RX/TX Support for Java serial communications
endef
CONFIGURE_ARGS += \
--disable-PRINTER
define Package/rxtx/install
$(INSTALL_DIR) \
$(1)/usr/lib/classpath
$(CP) $(PKG_BUILD_DIR)/$(GNU_TARGET_NAME)-gnu/.libs/*.so \
$(1)/usr/lib/classpath/
$(CP) $(PKG_BUILD_DIR)/RXTXcomm.jar \
$(1)/usr/lib/classpath/
endef
$(eval $(call BuildPackage,rxtx))

+ 0
- 11
libs/rxtx/patches/010-acm-devices.patch View File

@ -1,11 +0,0 @@
diff -rupN rxtx-2.2pre2/src/gnu/io/RXTXCommDriver.java rxtx-2.2pre2.new/src/gnu/io/RXTXCommDriver.java
--- rxtx-2.2pre2/src/gnu/io/RXTXCommDriver.java 2008-11-13 16:44:01.000000000 -0800
+++ rxtx-2.2pre2.new/src/gnu/io/RXTXCommDriver.java 2015-08-21 16:19:14.330743949 -0700
@@ -579,6 +579,7 @@ public class RXTXCommDriver implements C
"ttyUSB", // for USB frobs
"rfcomm", // bluetooth serial device
"ttyircomm", // linux IrCommdevices (IrDA serial emu)
+ "ttyACM" // linux CDC ACM devices
};
CandidatePortPrefixes=Temp;
}

Loading…
Cancel
Save