Browse Source

whois: fix compilation with glibc

Just don't install mkpasswd at all. It's not used and causes problems.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 3 years ago
parent
commit
273923d5d2
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
4 changed files with 21 additions and 23 deletions
  1. +1
    -1
      utils/whois/Makefile
  2. +0
    -11
      utils/whois/patches/010-no-crypt.patch
  3. +20
    -0
      utils/whois/patches/010-no-mkpasswd.patch
  4. +0
    -11
      utils/whois/patches/030-no-mkpasswd.patch

+ 1
- 1
utils/whois/Makefile View File

@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=whois
PKG_VERSION:=5.5.7
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/w/whois


+ 0
- 11
utils/whois/patches/010-no-crypt.patch View File

@ -1,11 +0,0 @@
--- a/Makefile
+++ b/Makefile
@@ -56,8 +56,6 @@ DEFS += -DHAVE_ICONV
endif
ifeq ($(shell $(PKG_CONFIG) --exists 'libxcrypt >= 4.1' || echo NO),)
-DEFS += -DHAVE_CRYPT_H -DHAVE_LINUX_CRYPT_GENSALT $(shell $(PKG_CONFIG) --cflags libcrypt)
-mkpasswd_LDADD += $(shell $(PKG_CONFIG) --libs libcrypt)
else ifdef HAVE_XCRYPT
DEFS += -DHAVE_XCRYPT_H -DHAVE_LINUX_CRYPT_GENSALT
mkpasswd_LDADD += -lxcrypt

+ 20
- 0
utils/whois/patches/010-no-mkpasswd.patch View File

@ -0,0 +1,20 @@
--- a/Makefile
+++ b/Makefile
@@ -72,7 +72,7 @@ endif
CPPFLAGS += $(DEFS) $(INCLUDES)
##############################################################################
-all: Makefile.depend whois mkpasswd pos
+all: Makefile.depend whois
##############################################################################
%.o: %.c
@@ -121,7 +121,7 @@ afl-run:
nice afl-fuzz -i ../afl_in -o ../afl_out -- ./whois
##############################################################################
-install: install-whois install-mkpasswd install-pos
+install: install-whois
install-whois: whois
$(INSTALL) -d $(BASEDIR)$(prefix)/bin/

+ 0
- 11
utils/whois/patches/030-no-mkpasswd.patch View File

@ -1,11 +0,0 @@
--- a/Makefile
+++ b/Makefile
@@ -62,7 +62,7 @@ endif
CPPFLAGS += $(DEFS) $(INCLUDES)
##############################################################################
-all: Makefile.depend whois mkpasswd pos
+all: Makefile.depend whois pos
##############################################################################
%.o: %.c

Loading…
Cancel
Save