Just don't install mkpasswd at all. It's not used and causes problems. Signed-off-by: Rosen Penev <rosenp@gmail.com>lilik-openwrt-22.03
@ -1,11 +0,0 @@ | |||||
--- a/Makefile | |||||
+++ b/Makefile | |||||
@@ -56,8 +56,6 @@ DEFS += -DHAVE_ICONV | |||||
endif | |||||
ifeq ($(shell $(PKG_CONFIG) --exists 'libxcrypt >= 4.1' || echo NO),) | |||||
-DEFS += -DHAVE_CRYPT_H -DHAVE_LINUX_CRYPT_GENSALT $(shell $(PKG_CONFIG) --cflags libcrypt) | |||||
-mkpasswd_LDADD += $(shell $(PKG_CONFIG) --libs libcrypt) | |||||
else ifdef HAVE_XCRYPT | |||||
DEFS += -DHAVE_XCRYPT_H -DHAVE_LINUX_CRYPT_GENSALT | |||||
mkpasswd_LDADD += -lxcrypt |
@ -0,0 +1,20 @@ | |||||
--- a/Makefile | |||||
+++ b/Makefile | |||||
@@ -72,7 +72,7 @@ endif | |||||
CPPFLAGS += $(DEFS) $(INCLUDES) | |||||
############################################################################## | |||||
-all: Makefile.depend whois mkpasswd pos | |||||
+all: Makefile.depend whois | |||||
############################################################################## | |||||
%.o: %.c | |||||
@@ -121,7 +121,7 @@ afl-run: | |||||
nice afl-fuzz -i ../afl_in -o ../afl_out -- ./whois | |||||
############################################################################## | |||||
-install: install-whois install-mkpasswd install-pos | |||||
+install: install-whois | |||||
install-whois: whois | |||||
$(INSTALL) -d $(BASEDIR)$(prefix)/bin/ |
@ -1,11 +0,0 @@ | |||||
--- a/Makefile | |||||
+++ b/Makefile | |||||
@@ -62,7 +62,7 @@ endif | |||||
CPPFLAGS += $(DEFS) $(INCLUDES) | |||||
############################################################################## | |||||
-all: Makefile.depend whois mkpasswd pos | |||||
+all: Makefile.depend whois pos | |||||
############################################################################## | |||||
%.o: %.c |