Browse Source

Merge pull request #14817 from neheb/sn

sane-backends: remove outdated C++ patch
lilik-openwrt-22.03
Rosen Penev 4 years ago
committed by GitHub
parent
commit
23bb8ec5ef
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
3 changed files with 3 additions and 19 deletions
  1. +2
    -2
      libs/libv4l/Makefile
  2. +1
    -1
      utils/sane-backends/Makefile
  3. +0
    -16
      utils/sane-backends/patches/101-fix_uclibc_std_rand.patch

+ 2
- 2
libs/libv4l/Makefile View File

@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=v4l-utils
PKG_VERSION:=1.20.0
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://www.linuxtv.org/downloads/v4l-utils
@ -78,7 +78,7 @@ endef
TARGET_CFLAGS += -flto
TARGET_CXXFLAGS += -std=c++11
TARGET_LDFLAGS += \
$(if $(CONFIG_LIBC_USE_GLIBC),,-largp) \
$(if $(CONFIG_USE_GLIBC),,-largp) \
-Wl,--gc-sections,--as-needed
CONFIGURE_ARGS+= \


+ 1
- 1
utils/sane-backends/Makefile View File

@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=sane-backends
PKG_VERSION:=1.0.31
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://gitlab.com/sane-project/backends/uploads/8bf1cae2e1803aefab9e5331550e5d5d/


+ 0
- 16
utils/sane-backends/patches/101-fix_uclibc_std_rand.patch View File

@ -1,16 +0,0 @@
https://gitlab.com/sane-project/backends/issues/237
--- a/backend/genesys/image_pipeline.cpp
+++ b/backend/genesys/image_pipeline.cpp
@@ -754,7 +754,11 @@ bool ImagePipelineNodeCalibrate::get_nex
float value_f = static_cast<float>(value) / max_value;
value_f = (value_f - offset_[curr_calib_i]) * multiplier_[curr_calib_i];
+#if defined(__UCLIBC__)
+ value_f = round(value_f * max_value);
+#else
value_f = std::round(value_f * max_value);
+#endif
value = clamp<std::int32_t>(static_cast<std::int32_t>(value_f), 0, max_value);
set_raw_channel_to_row(out_data, x, ch, value, format);

Loading…
Cancel
Save