Browse Source

sane-backends: remove outdated C++ patch

std::round was unavailable because of a wrong configure var from the
uClibc days. Fixed upstream with 1647790ae6

Refreshed patches with make package/sane-backends/refresh

Signed-off-by: Rosen Penev <rosenp@gmail.com>
lilik-openwrt-22.03
Rosen Penev 3 years ago
parent
commit
bf1a138f92
No known key found for this signature in database GPG Key ID: 36D31CFA845F0E3B
2 changed files with 1 additions and 17 deletions
  1. +1
    -1
      utils/sane-backends/Makefile
  2. +0
    -16
      utils/sane-backends/patches/101-fix_uclibc_std_rand.patch

+ 1
- 1
utils/sane-backends/Makefile View File

@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=sane-backends
PKG_VERSION:=1.0.31
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://gitlab.com/sane-project/backends/uploads/8bf1cae2e1803aefab9e5331550e5d5d/


+ 0
- 16
utils/sane-backends/patches/101-fix_uclibc_std_rand.patch View File

@ -1,16 +0,0 @@
https://gitlab.com/sane-project/backends/issues/237
--- a/backend/genesys/image_pipeline.cpp
+++ b/backend/genesys/image_pipeline.cpp
@@ -754,7 +754,11 @@ bool ImagePipelineNodeCalibrate::get_nex
float value_f = static_cast<float>(value) / max_value;
value_f = (value_f - offset_[curr_calib_i]) * multiplier_[curr_calib_i];
+#if defined(__UCLIBC__)
+ value_f = round(value_f * max_value);
+#else
value_f = std::round(value_f * max_value);
+#endif
value = clamp<std::int32_t>(static_cast<std::int32_t>(value_f), 0, max_value);
set_raw_channel_to_row(out_data, x, ch, value, format);

Loading…
Cancel
Save