Browse Source

Merge pull request #1158 from commodo/python-ncurses

python: force libncurses
lilik-openwrt-22.03
Steven Barth 10 years ago
parent
commit
14f680ea3b
2 changed files with 16 additions and 1 deletions
  1. +1
    -1
      lang/python/files/python-package-ncurses.mk
  2. +15
    -0
      lang/python/patches/011-do-not-prefer-ncursesw.patch

+ 1
- 1
lang/python/files/python-package-ncurses.mk View File

@ -8,7 +8,7 @@
define Package/python-ncurses
$(call Package/python/Default)
TITLE:=Python $(PYTHON_VERSION) ncurses module
DEPENDS:=+python-light +libncursesw
DEPENDS:=+python-light +libncurses
endef
$(eval $(call PyBasePackage,python-ncurses, \


+ 15
- 0
lang/python/patches/011-do-not-prefer-ncursesw.patch View File

@ -0,0 +1,15 @@
diff --git a/setup.py b/setup.py
index 7868b7b..86b0119 100644
--- a/setup.py
+++ b/setup.py
@@ -725,8 +725,8 @@ class PyBuildExt(build_ext):
# use the same library for the readline and curses modules.
if 'curses' in readline_termcap_library:
curses_library = readline_termcap_library
- elif self.compiler.find_library_file(lib_dirs, 'ncursesw'):
- curses_library = 'ncursesw'
+ #elif self.compiler.find_library_file(lib_dirs, 'ncursesw'):
+ # curses_library = 'ncursesw'
elif self.compiler.find_library_file(lib_dirs, 'ncurses'):
curses_library = 'ncurses'
elif self.compiler.find_library_file(lib_dirs, 'curses'):

Loading…
Cancel
Save