Browse Source

Merge pull request #1157 from commodo/python3-ncurses

python3: force libncurses
lilik-openwrt-22.03
Steven Barth 10 years ago
parent
commit
18b4792033
2 changed files with 16 additions and 1 deletions
  1. +1
    -1
      lang/python3/files/python3-package-ncurses.mk
  2. +15
    -0
      lang/python3/patches/011-do-not-prefer-ncursesw.patch

+ 1
- 1
lang/python3/files/python3-package-ncurses.mk View File

@ -8,7 +8,7 @@
define Package/python3-ncurses
$(call Package/python3/Default)
TITLE:=Python $(PYTHON3_VERSION) ncurses module
DEPENDS:=+python3-light +libncursesw
DEPENDS:=+python3-light +libncurses
endef
$(eval $(call Py3BasePackage,python3-ncurses, \


+ 15
- 0
lang/python3/patches/011-do-not-prefer-ncursesw.patch View File

@ -0,0 +1,15 @@
diff --git a/setup.py b/setup.py
index 2779658..b6d3d61 100644
--- a/setup.py
+++ b/setup.py
@@ -693,8 +693,8 @@ class PyBuildExt(build_ext):
# use the same library for the readline and curses modules.
if 'curses' in readline_termcap_library:
curses_library = readline_termcap_library
- elif self.compiler.find_library_file(lib_dirs, 'ncursesw'):
- curses_library = 'ncursesw'
+ #elif self.compiler.find_library_file(lib_dirs, 'ncursesw'):
+ # curses_library = 'ncursesw'
elif self.compiler.find_library_file(lib_dirs, 'ncurses'):
curses_library = 'ncurses'
elif self.compiler.find_library_file(lib_dirs, 'curses'):

Loading…
Cancel
Save