|
--- a/src/Makefile
|
|
+++ b/src/Makefile
|
|
@@ -1,7 +1,7 @@
|
|
# In case of windows, use os_cygwin=yes setting in the configuration file (smsd.conf).
|
|
|
|
# Select your setup size:
|
|
-CFLAGS = -D NUMBER_OF_MODEMS=64
|
|
+CFLAGS ?= -D NUMBER_OF_MODEMS=64
|
|
|
|
# Uncomment for Solaris
|
|
# CFLAGS += -D SOLARIS
|
|
@@ -43,7 +43,7 @@ smsd: smsd.c extras.o locking.o cfgfile.
|
|
|
|
ifneq (,$(findstring SOLARIS,$(CFLAGS)))
|
|
ifeq (,$(findstring DISABLE_INET_SOCKET,$(CFLAGS)))
|
|
-override LFLAGS += -lsocket -lnsl
|
|
+ override LFLAGS += -lsocket -lnsl
|
|
endif
|
|
endif
|
|
|