|
--- a/Lib/distutils/sysconfig.py
|
|
+++ b/Lib/distutils/sysconfig.py
|
|
@@ -445,6 +445,7 @@ def _init_posix():
|
|
platform=sys.platform,
|
|
multiarch=getattr(sys.implementation, '_multiarch', ''),
|
|
))
|
|
+ name = '_sysconfigdata'
|
|
_temp = __import__(name, globals(), locals(), ['build_time_vars'], 0)
|
|
build_time_vars = _temp.build_time_vars
|
|
global _config_vars
|
|
--- a/Lib/sysconfig.py
|
|
+++ b/Lib/sysconfig.py
|
|
@@ -344,6 +344,7 @@ def get_makefile_filename():
|
|
|
|
|
|
def _get_sysconfigdata_name():
|
|
+ return '_sysconfigdata'
|
|
return os.environ.get('_PYTHON_SYSCONFIGDATA_NAME',
|
|
'_sysconfigdata_{abi}_{platform}_{multiarch}'.format(
|
|
abi=sys.abiflags,
|
|
--- a/Makefile.pre.in
|
|
+++ b/Makefile.pre.in
|
|
@@ -1460,7 +1460,7 @@ libinstall: build_all $(srcdir)/Modules/
|
|
esac; \
|
|
done; \
|
|
done
|
|
- $(INSTALL_DATA) `cat pybuilddir.txt`/_sysconfigdata_$(ABIFLAGS)_$(MACHDEP)_$(MULTIARCH).py \
|
|
+ $(INSTALL_DATA) `cat pybuilddir.txt`/_sysconfigdata*.py \
|
|
$(DESTDIR)$(LIBDEST); \
|
|
$(INSTALL_DATA) $(srcdir)/LICENSE $(DESTDIR)$(LIBDEST)/LICENSE.txt
|
|
ifeq (@COMPILE_ALL_TESTS@,yes)
|
|
@@ -1618,7 +1618,7 @@ sharedinstall: sharedmods
|
|
--install-scripts=$(BINDIR) \
|
|
--install-platlib=$(DESTSHARED) \
|
|
--root=$(DESTDIR)/
|
|
- -rm $(DESTDIR)$(DESTSHARED)/_sysconfigdata_$(ABIFLAGS)_$(MACHDEP)_$(MULTIARCH).py
|
|
+ -rm $(DESTDIR)$(DESTSHARED)/_sysconfigdata*.py
|
|
-rm -r $(DESTDIR)$(DESTSHARED)/__pycache__
|
|
|
|
# Here are a couple of targets for MacOSX again, to install a full
|
|
--- a/configure
|
|
+++ b/configure
|
|
@@ -15213,7 +15213,7 @@ else
|
|
fi
|
|
|
|
|
|
-if test x$PLATFORM_TRIPLET = x; then
|
|
+if true ; then
|
|
LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}"
|
|
else
|
|
LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}-${PLATFORM_TRIPLET}"
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -4688,7 +4688,7 @@ fi
|
|
|
|
dnl define LIBPL after ABIFLAGS and LDVERSION is defined.
|
|
AC_SUBST(PY_ENABLE_SHARED)
|
|
-if test x$PLATFORM_TRIPLET = x; then
|
|
+if true ; then
|
|
LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}"
|
|
else
|
|
LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}-${PLATFORM_TRIPLET}"
|