|
From 6b320186db7df1e58fdd2c836af54c86cc596981 Mon Sep 17 00:00:00 2001
|
|
From: Jussi Kukkonen <jussi.kukkonen@intel.com>
|
|
Date: Sat, 24 Feb 2018 15:09:10 +0100
|
|
Subject: [PATCH] [PATCH 1/4] Remove redundant compiler sanity checks
|
|
|
|
AC_PROG_CC already performs sanity checks. And unlike the removed
|
|
checks, it does so in a way that supports cross compilation.
|
|
|
|
Modified from patch by Maarten ter Huurne.
|
|
|
|
Upstream-Status: Submitted [http://savannah.gnu.org/bugs/?43223]
|
|
|
|
Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
|
|
---
|
|
configure.ac | 27 ---------------------------
|
|
1 file changed, 27 deletions(-)
|
|
|
|
diff --git a/src/configure.ac b/src/configure.ac
|
|
index d1bc42c..a8208ea 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -48,31 +48,6 @@ AC_PROG_GCC_TRADITIONAL
|
|
AC_ISC_POSIX
|
|
AC_USE_SYSTEM_EXTENSIONS
|
|
|
|
-AC_TRY_RUN(main(){exit(0);},,[
|
|
-if test $CC != cc ; then
|
|
-AC_NOTE(Your $CC failed - restarting with CC=cc)
|
|
-AC_NOTE()
|
|
-CC=cc
|
|
-export CC
|
|
-exec $0 $configure_args
|
|
-fi
|
|
-])
|
|
-
|
|
-AC_TRY_RUN(main(){exit(0);},,
|
|
-exec 5>&2
|
|
-eval $ac_link
|
|
-AC_NOTE(CC=$CC; CFLAGS=$CFLAGS; LIBS=$LIBS;)
|
|
-AC_NOTE($ac_compile)
|
|
-AC_MSG_ERROR(Can't run the compiler - sorry))
|
|
-
|
|
-AC_TRY_RUN([
|
|
-main()
|
|
-{
|
|
- int __something_strange_();
|
|
- __something_strange_(0);
|
|
-}
|
|
-],AC_MSG_ERROR(Your compiler does not set the exit status - sorry))
|
|
-
|
|
AC_PROG_AWK
|
|
|
|
AC_PROG_INSTALL
|
|
@@ -1278,8 +1253,6 @@ fi
|
|
dnl Ptx bug workaround -- insert -lc after -ltermcap
|
|
test -n "$seqptx" && LIBS="-ltermcap -lc -lsocket -linet -lnsl -lsec -lseq"
|
|
|
|
-AC_TRY_RUN(main(){exit(0);},,AC_MSG_ERROR(Can't run the compiler - internal error. Sorry.))
|
|
-
|
|
ETCSCREENRC=
|
|
AC_MSG_CHECKING(for the global screenrc file)
|
|
AC_ARG_WITH(sys-screenrc, [ --with-sys-screenrc=path to the global screenrc file], [ ETCSCREENRC="${withval}" ])
|
|
--
|
|
2.17.1
|
|
|