|
--- a/src/CMakeLists.txt
|
|
+++ b/src/CMakeLists.txt
|
|
@@ -129,20 +129,20 @@ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/avro-c.pc
|
|
DESTINATION lib/pkgconfig)
|
|
|
|
add_executable(avrocat avrocat.c)
|
|
-target_link_libraries(avrocat avro-static)
|
|
+target_link_libraries(avrocat avro-shared)
|
|
install(TARGETS avrocat RUNTIME DESTINATION bin)
|
|
|
|
add_executable(avroappend avroappend.c)
|
|
-target_link_libraries(avroappend avro-static)
|
|
+target_link_libraries(avroappend avro-shared)
|
|
install(TARGETS avroappend RUNTIME DESTINATION bin)
|
|
|
|
if (NOT WIN32)
|
|
#TODO: Port getopt() to Windows to compile avropipe.c and avromod.c
|
|
add_executable(avropipe avropipe.c)
|
|
-target_link_libraries(avropipe avro-static)
|
|
+target_link_libraries(avropipe avro-shared)
|
|
install(TARGETS avropipe RUNTIME DESTINATION bin)
|
|
|
|
add_executable(avromod avromod.c)
|
|
-target_link_libraries(avromod avro-static)
|
|
+target_link_libraries(avromod avro-shared)
|
|
install(TARGETS avromod RUNTIME DESTINATION bin)
|
|
endif(NOT WIN32)
|