|
--- a/Makefile.SH 2017-10-15 18:57:08.436234652 -0600
|
|
+++ b/Makefile.SH 2017-10-15 19:02:47.587658819 -0600
|
|
@@ -328,7 +328,7 @@ PATH_SEP = $p_
|
|
# Macros to invoke a copy of miniperl during the build. Targets which
|
|
# are built using these macros should depend on \$(MINIPERL_EXE)
|
|
MINIPERL_EXE = miniperl\$(EXE_EXT)
|
|
-MINIPERL = \$(LDLIBPTH) ./miniperl\$(EXE_EXT) -Ilib
|
|
+MINIPERL = \$(LDLIBPTH) ./miniperl\$(EXE_EXT) -Ilib -I.
|
|
|
|
# Macros to invoke sort the MANIFEST during build
|
|
MANIFEST_SRT = MANIFEST.srt
|
|
@@ -991,7 +991,7 @@ NAMESPACEFLAGS = -force_flat_namespace
|
|
@$(RMS) miniperl.xok
|
|
$(CC) $(CLDFLAGS) $(NAMESPACEFLAGS) -o $(MINIPERL_EXE) \
|
|
$(miniperl_objs) $(libs)
|
|
- $(LDLIBPTH) ./miniperl$(HOST_EXE_EXT) -w -Ilib -Idist/Exporter/lib -MExporter -e '<?>' || sh -c 'echo >&2 Failed to build miniperl. Please run make minitest; exit 1'
|
|
+ $(LDLIBPTH) ./miniperl$(HOST_EXE_EXT) -w -Ilib -I. -Idist/Exporter/lib -MExporter -e '<?>' || sh -c 'echo >&2 Failed to build miniperl. Please run make minitest; exit 1'
|
|
$(MINIPERL) -f write_buildcustomize.pl
|
|
!NO!SUBS!
|
|
;;
|
|
@@ -1002,16 +1002,16 @@ lib/buildcustomize.pl: $& $(miniperl_obj
|
|
@\$(RMS) miniperl.xok
|
|
@\$(RMS) \$(MINIPERL_EXE)
|
|
\$(LNS) \$(HOST_PERL) \$(MINIPERL_EXE)
|
|
- \$(LDLIBPTH) ./miniperl\$(HOST_EXE_EXT) -w -Ilib -Idist/Exporter/lib -MExporter -e '<?>' || sh -c 'echo >&2 Failed to build miniperl. Please run make minitest; exit 1'
|
|
+ \$(LDLIBPTH) ./miniperl\$(HOST_EXE_EXT) -w -Ilib -I. -Idist/Exporter/lib -MExporter -e '<?>' || sh -c 'echo >&2 Failed to build miniperl. Please run make minitest; exit 1'
|
|
\$(MINIPERL) -f write_buildcustomize.pl 'osname' "$osname"
|
|
!GROK!THIS!
|
|
else
|
|
$spitshell >>$Makefile <<'!NO!SUBS!'
|
|
lib/buildcustomize.pl: $& $(miniperl_dep) write_buildcustomize.pl
|
|
@$(RMS) miniperl.xok
|
|
$(CC) $(CLDFLAGS) -o $(MINIPERL_EXE) \
|
|
$(miniperl_objs) $(libs)
|
|
- $(LDLIBPTH) ./miniperl$(HOST_EXE_EXT) -w -Ilib -Idist/Exporter/lib -MExporter -e '<?>' || sh -c 'echo >&2 Failed to build miniperl. Please run make minitest; exit 1'
|
|
+ $(LDLIBPTH) ./miniperl$(HOST_EXE_EXT) -w -Ilib -I. -Idist/Exporter/lib -MExporter -e '<?>' || sh -c 'echo >&2 Failed to build miniperl. Please run make minitest; exit 1'
|
|
$(MINIPERL) -f write_buildcustomize.pl
|
|
!NO!SUBS!
|
|
fi
|