diff --git a/pycparser/c_lexer.py b/pycparser/c_lexer.py
|
|
index cbb9d26..cbd7742 100644
|
|
--- a/pycparser/c_lexer.py
|
|
+++ b/pycparser/c_lexer.py
|
|
@@ -9,8 +9,8 @@
|
|
import re
|
|
import sys
|
|
|
|
-from .ply import lex
|
|
-from .ply.lex import TOKEN
|
|
+from ply import lex
|
|
+from ply.lex import TOKEN
|
|
|
|
|
|
class CLexer(object):
|
|
diff --git a/pycparser/c_parser.py b/pycparser/c_parser.py
|
|
index f4f7453..5c0ca88 100644
|
|
--- a/pycparser/c_parser.py
|
|
+++ b/pycparser/c_parser.py
|
|
@@ -8,7 +8,7 @@
|
|
#------------------------------------------------------------------------------
|
|
import re
|
|
|
|
-from .ply import yacc
|
|
+from ply import yacc
|
|
|
|
from . import c_ast
|
|
from .c_lexer import CLexer
|
|
diff --git a/setup.py b/setup.py
|
|
index fdccbb3..036a10b 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -49,7 +49,7 @@ setup(
|
|
classifiers = [
|
|
'Programming Language :: Python :: 2',
|
|
'Programming Language :: Python :: 3',],
|
|
- packages=['pycparser', 'pycparser.ply'],
|
|
+ packages=['pycparser'],
|
|
package_data={'pycparser': ['*.cfg']},
|
|
cmdclass={'install': install, 'sdist': sdist},
|
|
)
|