You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

26 lines
798 B

--- a/configure.ac
+++ b/configure.ac
@@ -138,11 +138,17 @@ AS_IF([test "x$enable_android" = "xyes"], [
# Checks for library functions.
AC_CHECK_FUNCS([gethostname socket])
- # Check for presence of pdfLaTeX
- AC_CHECK_PROG(PDFLATEX, pdflatex, pdflatex)
- if test -z "$PDFLATEX"; then
- AC_MSG_WARN([Unable to create PDF version of the documentation.])
- fi
+ AC_ARG_ENABLE([docs],
+ AS_HELP_STRING([--enable-docs], [Build documentation using PDFLaTeX]),
+ [
+ # Check for presence of pdfLaTeX
+ AC_CHECK_PROG(PDFLATEX, pdflatex, pdflatex)
+ if test -z "$PDFLATEX"; then
+ AC_MSG_WARN([Unable to create PDF version of the documentation.])
+ fi
+ ], [
+ PDFLATEX="no"
+ ])
AC_ARG_ENABLE([libdaemon],
AS_HELP_STRING([--disable-libdaemon], [Build without libdaemon support]),
--