|
Fix cross-compilation
|
|
|
|
Patch was backported from Apache httpd:
|
|
http://svn.apache.org/viewvc?view=revision&revision=1327907
|
|
http://svn.apache.org/viewvc?view=revision&revision=1328390
|
|
http://svn.apache.org/viewvc?view=revision&revision=1328714
|
|
|
|
Patch submitted upstream:
|
|
https://issues.apache.org/bugzilla/show_bug.cgi?id=57058
|
|
|
|
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
|
|
--- a/configure.in
|
|
+++ b/configure.in
|
|
@@ -118,6 +118,16 @@ AC_CANONICAL_SYSTEM
|
|
echo "Configuring APR library"
|
|
echo "Platform: $host"
|
|
|
|
+dnl In case of cross compilation we set CC_FOR_BUILD to cc unless
|
|
+dnl we got already CC_FOR_BUILD from environment.
|
|
+if test "x${build_alias}" != "x${host_alias}"; then
|
|
+ if test "x${CC_FOR_BUILD}" = "x"; then
|
|
+ CC_FOR_BUILD=cc
|
|
+ fi
|
|
+fi
|
|
+AC_SUBST(CC_FOR_BUILD)
|
|
+AC_SUBST(CFLAGS_FOR_BUILD)
|
|
+
|
|
dnl Some initial steps for configuration. We setup the default directory
|
|
dnl and which files are to be configured.
|
|
|
|
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -8,6 +8,8 @@ top_blddir=@apr_builddir@
|
|
# APR (Apache Portable Runtime) library Makefile.
|
|
#
|
|
CPP = @CPP@
|
|
+CC_FOR_BUILD = @CC_FOR_BUILD@
|
|
+CFLAGS_FOR_BUILD = @CFLAGS_FOR_BUILD@
|
|
|
|
# get substituted into some targets
|
|
APR_MAJOR_VERSION=@APR_MAJOR_VERSION@
|
|
@@ -136,8 +138,13 @@ tools/gen_test_char.lo: tools/gen_test_c
|
|
$(APR_MKDIR) tools
|
|
$(LT_COMPILE)
|
|
|
|
+ifdef CC_FOR_BUILD
|
|
+tools/gen_test_char@EXEEXT@: tools/gen_test_char.c $(LOCAL_LIBS)
|
|
+ $(CC_FOR_BUILD) $(CFLAGS_FOR_BUILD) -DCROSS_COMPILE -o $@ $<
|
|
+else
|
|
tools/gen_test_char@EXEEXT@: $(OBJECTS_gen_test_char)
|
|
$(LINK_PROG) $(OBJECTS_gen_test_char) $(ALL_LIBS)
|
|
+endif
|
|
|
|
include/private/apr_escape_test_char.h: tools/gen_test_char@EXEEXT@
|
|
$(APR_MKDIR) include/private
|