|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -424,15 +424,6 @@ endif
|
|
override ARCH := $(strip $(call debug_shell,$(CC) $(CPPFLAGS) -E archtest.c 2>/dev/null | grep -v '^\#' | grep '"' | cut -f 2 -d'"'))
|
|
override ENDIAN := $(strip $(call debug_shell,$(CC) $(CPPFLAGS) -E endiantest.c 2>/dev/null | grep -v '^\#'))
|
|
|
|
-# Disable the internal programmer on unsupported architectures (everything but x86 and mipsel)
|
|
-ifneq ($(ARCH)-little, $(filter $(ARCH),x86 mips)-$(ENDIAN))
|
|
-ifeq ($(CONFIG_INTERNAL), yes)
|
|
-UNSUPPORTED_FEATURES += CONFIG_INTERNAL=yes
|
|
-else
|
|
-override CONFIG_INTERNAL = no
|
|
-endif
|
|
-endif
|
|
-
|
|
# PCI port I/O support is unimplemented on PPC/MIPS/SPARC and unavailable on ARM.
|
|
# Right now this means the drivers below only work on x86.
|
|
ifneq ($(ARCH), x86)
|