You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

18 lines
414 B

--- a/nss/coreconf/arch.mk
+++ b/nss/coreconf/arch.mk
@@ -20,13 +20,13 @@
# Macros for getting the OS architecture
#
-OS_ARCH := $(subst /,_,$(shell uname -s))
+OS_ARCH ?= $(subst /,_,$(shell uname -s))
#
# Attempt to differentiate between sparc and x86 Solaris
#
-OS_TEST := $(shell uname -m)
+OS_TEST ?= $(shell uname -m)
ifeq ($(OS_TEST),i86pc)
OS_RELEASE := $(shell uname -r)_$(OS_TEST)
else