From 94fa0bba88740b9ab58c5805ddb24b05b2635f34 Mon Sep 17 00:00:00 2001
|
|
From: Mike Gelfand <mikedld@mikedld.com>
|
|
Date: Fri, 26 Jan 2018 08:31:16 +0300
|
|
Subject: [PATCH] Fix FTCBFS due to AC_RUN_IFELSE (patch by Helmut Grohne)
|
|
|
|
Fixes: #475
|
|
---
|
|
configure.ac | 8 +++-----
|
|
1 file changed, 3 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index cb026df..335f4a7 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -390,14 +390,12 @@ dnl Let's hope it's 1.7 or higher, since it provides
|
|
dnl MINIUPNPC_API_VERSION and we won't have to figure
|
|
dnl it out on our own
|
|
if test "x$upnp_version" = "xunknown" ; then
|
|
- AC_RUN_IFELSE(
|
|
+ AC_COMPILE_IFELSE(
|
|
[AC_LANG_PROGRAM(
|
|
[#include <stdlib.h>
|
|
#include <miniupnpc/miniupnpc.h>],
|
|
- [#ifdef MINIUPNPC_API_VERSION
|
|
- return EXIT_SUCCESS;
|
|
- #else
|
|
- return EXIT_FAILURE;
|
|
+ [#ifndef MINIUPNPC_API_VERSION
|
|
+ #error MINIUPNPC_API_VERSION undefined
|
|
#endif]
|
|
)],
|
|
[upnp_version=">= 1.7"]
|
|
--
|
|
2.7.4
|
|
|