|
--- a/lib/Makefile.am
|
|
+++ b/lib/Makefile.am
|
|
@@ -1,3 +1,5 @@
|
|
+include $(TOPDIR)/rules.mk
|
|
+
|
|
pcfiles = libseafile.pc
|
|
pkgconfig_DATA = $(pcfiles)
|
|
pkgconfigdir = $(libdir)/pkgconfig
|
|
@@ -56,7 +58,7 @@ rpc_table.stamp: ${top_srcdir}/lib/rpc_t
|
|
@rm -f rpc_table.tmp
|
|
@touch rpc_table.tmp
|
|
@echo "[libsearpc]: generating rpc header files"
|
|
- @PYTHON@ `which searpc-codegen.py` ${top_srcdir}/lib/rpc_table.py
|
|
+ @PYTHON@ "$(STAGING_DIR)/usr/bin/searpc-codegen.py" ${top_srcdir}/lib/rpc_table.py
|
|
@echo "[libsearpc]: done"
|
|
@mv -f rpc_table.tmp $@
|
|
|
|
@@ -82,5 +84,5 @@ install-data-local:
|
|
if MACOS
|
|
sed -i '' -e "s|(DESTDIR)|${DESTDIR}|g" $(pcfiles)
|
|
else
|
|
- ${SED} -i "s|(DESTDIR)|${DESTDIR}|g" $(pcfiles)
|
|
+ ${SED} "s|(DESTDIR)|${DESTDIR}|g" $(pcfiles)
|
|
endif
|