--- a/pycparser/c_lexer.py
|
|
+++ b/pycparser/c_lexer.py
|
|
@@ -9,8 +9,8 @@
|
|
import re
|
|
import sys
|
|
|
|
-from .ply import lex
|
|
-from .ply.lex import TOKEN
|
|
+from ply import lex
|
|
+from ply.lex import TOKEN
|
|
|
|
|
|
class CLexer(object):
|
|
--- a/pycparser/c_parser.py
|
|
+++ b/pycparser/c_parser.py
|
|
@@ -8,7 +8,7 @@
|
|
#------------------------------------------------------------------------------
|
|
import re
|
|
|
|
-from .ply import yacc
|
|
+from ply import yacc
|
|
|
|
from . import c_ast
|
|
from .c_lexer import CLexer
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -60,7 +60,7 @@ setup(
|
|
'Programming Language :: Python :: 3.6',
|
|
],
|
|
python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",
|
|
- packages=['pycparser', 'pycparser.ply'],
|
|
+ packages=['pycparser'],
|
|
package_data={'pycparser': ['*.cfg']},
|
|
cmdclass={'install': install, 'sdist': sdist},
|
|
)
|