|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -51,7 +51,7 @@ AC_CHECK_HEADERS(stdio.h stdlib.h string
|
|
syslog.h time.h errno.h sys/types.h sys/stat.h netinet/in.h \
|
|
math.h sys/socket.h dirent.h ctype.h \
|
|
mtent.h fcntl.h sys/param.h arpa/inet.h \
|
|
- sys/vfs.h sys/pstat.h sys/sysinfo.h sys/statvfs.h sys/statfs.h \
|
|
+ sys/vfs.h sys/pstat.h sys/statvfs.h sys/statfs.h \
|
|
sys/socket.h sys/loadavg.h arpa/inet.h \
|
|
sys/vmmeter.h strings.h vm/vm_param.h \
|
|
sys/time.h kstat.h sys/syscall.h sys/sysmacros.h \
|
|
@@ -63,6 +63,11 @@ AC_CHECK_HEADERS(stdio.h stdlib.h string
|
|
Winber.h lber.h ws2tcpip.h inttypes.h sys/file.h grp.h \
|
|
execinfo.h libperfstat.h sys/systemcfg.h sys/mnttab.h mntent.h sys/times.h \
|
|
dlfcn.h sys/utsname.h)
|
|
+AC_CHECK_HEADERS(sys/sysinfo.h, [], [], [
|
|
+#ifdef HAVE_LINUX_KERNEL_H
|
|
+# include <linux/kernel.h>
|
|
+#endif
|
|
+])
|
|
AC_CHECK_HEADERS(resolv.h, [], [], [
|
|
#ifdef HAVE_SYS_TYPES_H
|
|
# include <sys/types.h>
|