You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
 

14 lines
438 B

OpenWrt (modification):
Fix cross compile errors by inserting an environment variable for the
target. Use "uname" on host only if "UNAME" variable is empty.
--- a/configure.ac
+++ b/configure.ac
@@ -815,7 +815,7 @@ if test x_$ub_test_python != x_no; then
fi
fi
-if test "`uname`" = "NetBSD"; then
+if test "${UNAME:-`uname`}" = "NetBSD"; then
NETBSD_LINTFLAGS='"-D__RENAME(x)=" -D_NETINET_IN_H_'
AC_SUBST(NETBSD_LINTFLAGS)
fi