--- /dev/null
|
|
+++ b/acinclude.m4
|
|
@@ -0,0 +1 @@
|
|
+sinclude(m4/libprelude.m4)
|
|
--- a/configure.in
|
|
+++ b/configure.in
|
|
@@ -285,21 +285,7 @@ AC_CHECK_TYPES([int8_t,int16_t,int32_t,i
|
|
AC_CHECK_TYPES([boolean])
|
|
|
|
# In case INADDR_NONE is not defined (like on Solaris)
|
|
-have_inaddr_none="no"
|
|
-AC_MSG_CHECKING([for INADDR_NONE])
|
|
-AC_RUN_IFELSE(
|
|
-[AC_LANG_PROGRAM(
|
|
-[[
|
|
-#include <sys/types.h>
|
|
-#include <netinet/in.h>
|
|
-#include <arpa/inet.h>
|
|
-]],
|
|
-[[
|
|
- if (inet_addr("10,5,2") == INADDR_NONE);
|
|
- return 0;
|
|
-]])],
|
|
-[have_inaddr_none="yes"],
|
|
-[have_inaddr_none="no"])
|
|
+have_inaddr_none="yes"
|
|
AC_MSG_RESULT($have_inaddr_none)
|
|
if test "x$have_inaddr_none" = "xno"; then
|
|
AC_DEFINE([INADDR_NONE],[-1],[For INADDR_NONE definition])
|
|
@@ -433,16 +419,7 @@ if test "x$LPCAP" = "xno"; then
|
|
fi
|
|
|
|
AC_MSG_CHECKING([for pcap_lex_destroy])
|
|
-AC_RUN_IFELSE(
|
|
-[AC_LANG_PROGRAM(
|
|
-[[
|
|
-#include <pcap.h>
|
|
-]],
|
|
-[[
|
|
- pcap_lex_destroy();
|
|
-]])],
|
|
-[have_pcap_lex_destroy="yes"],
|
|
-[have_pcap_lex_destroy="no"])
|
|
+have_pcap_lex_destroy="yes"
|
|
AC_MSG_RESULT($have_pcap_lex_destroy)
|
|
if test "x$have_pcap_lex_destroy" = "xyes"; then
|
|
AC_DEFINE([HAVE_PCAP_LEX_DESTROY],[1],[Can cleanup lex buffer stack created by pcap bpf filter])
|
|
@@ -727,54 +704,21 @@ if test "x$ac_cv_func_daq_dp_add_dc" = "
|
|
|
|
fi
|
|
|
|
-AC_MSG_CHECKING([for daq address space ID])
|
|
-AC_RUN_IFELSE(
|
|
-[AC_LANG_PROGRAM(
|
|
-[[
|
|
-#include <daq.h>
|
|
-]],
|
|
-[[
|
|
- DAQ_PktHdr_t hdr;
|
|
- hdr.address_space_id = 0;
|
|
-]])],
|
|
-[have_daq_address_space_id="yes"],
|
|
-[have_daq_address_space_id="no"])
|
|
+have_daq_address_space_id="yes"
|
|
AC_MSG_RESULT($have_daq_address_space_id)
|
|
if test "x$have_daq_address_space_id" = "xyes"; then
|
|
AC_DEFINE([HAVE_DAQ_ADDRESS_SPACE_ID],[1],
|
|
[DAQ version supports address space ID in header.])
|
|
fi
|
|
|
|
-AC_MSG_CHECKING([for daq flow ID])
|
|
-AC_RUN_IFELSE(
|
|
-[AC_LANG_PROGRAM(
|
|
-[[
|
|
-#include <daq.h>
|
|
-]],
|
|
-[[
|
|
- DAQ_PktHdr_t hdr;
|
|
- hdr.flow_id = 0;
|
|
-]])],
|
|
-[have_daq_flow_id="yes"],
|
|
-[have_daq_flow_id="no"])
|
|
+have_daq_flow_id="yes"
|
|
AC_MSG_RESULT($have_daq_flow_id)
|
|
if test "x$have_daq_flow_id" = "xyes"; then
|
|
AC_DEFINE([HAVE_DAQ_FLOW_ID],[1],
|
|
[DAQ version supports flow ID in header.])
|
|
fi
|
|
|
|
-AC_MSG_CHECKING([for DAQ_VERDICT_RETRY])
|
|
-AC_RUN_IFELSE(
|
|
-[AC_LANG_PROGRAM(
|
|
-[[
|
|
-#include <daq.h>
|
|
-]],
|
|
-[[
|
|
- DAQ_Verdict verdict;
|
|
- verdict = DAQ_VERDICT_RETRY;
|
|
-]])],
|
|
-[have_daq_verdict_retry="yes"],
|
|
-[have_daq_verdict_retry="no"])
|
|
+have_daq_verdict_retry="yes"
|
|
AC_MSG_RESULT($have_daq_verdict_retry)
|
|
if test "x$have_daq_verdict_retry" = "xyes"; then
|
|
AC_DEFINE([HAVE_DAQ_VERDICT_RETRY],[1],
|